Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

On my Galaxy Nexus running (stock, non-rooted) ICS, there is a contact entry for "ME".

This is different from the contact entry farther down the list with my actual name on it. And the contact for "ME" actually contains some incorrect information. Some non-existent email addresses, etc. I don't even know where these came from, as they aren't anywhere in my contacts lists nor in my G+ profile.

When I try to edit "ME", it does not give me the option to modify the email addresses. And it also doesn't let me Join this contact with the other instance of myself.

How can I edit this "ME" contact to show correct information? Or can I somehow delete it and choose a different contact to represent ME?

share|improve this question
    
I looks to me that a lot of this info comes from your Google+ profile. I'm looking into it further. –  Al E. Dec 22 '11 at 19:03
1  
Possible duplicate of: android.stackexchange.com/q/17159/4168 –  Marius Butuc Dec 22 '11 at 19:42
    
For what it's worth, it looks like the majority of the outdated information I'm seeing in my entry came from my Google+ profile. I've since edited that, and "refreshed" in the Google+ app, but the information remains. Annoying, to say the least. I'm inclined to call this a bug. –  Al E. Dec 30 '11 at 15:33
    
In my case, this info was never in my Google+ profile. The only connection that I can see is that one of the email addresses used to (but doesn't anymore) forward to my gmail address. But hopefully this is something that they can address in an ICS update, either to make the "ME" contact more editable or more refreshable. –  Josh Dec 30 '11 at 16:14
add comment

12 Answers

up vote 6 down vote accepted

I also had the same problem and it took me 2 days to fix this

Try going to contacts.google.com.

Find your profile (should have your gmail on email address)

Re-add the faulty data (it was an old phone number in my case), save, and force your nexus to sync contacts

Now delete the faulty data, sava, and force sync again.

If that didnt work, do the same but with your google+ profile: re-add faulty data, save, and force sync, then delete it.

I did both of the above, so I'm not exactly sure which method worked

Edit: just remembered there was one other thing i did after all of the above:

Go to google plus app on your nexus

Click "settings" and uncheck the contacts syncing.

The old phone number was removed at this point. And turning sync back on did not make it reappear

Hope that helped!

share|improve this answer
    
I haven't thought about this question in a while, and I just went and looked and my ME contact was magically correct (all the crappy old email addresses were gone); who knows what happened. But I'm still marking this as Best Answer because you put a lot of effort into a specific answer. Thanks! –  Josh Mar 6 '12 at 16:25
add comment

I posted my fix on the Google Mobile Help Forum.

I couldn't get the Me profile to update, so I deleted it. There was a warning that it would just be hidden, but after I did it, I couldn't find a way to bring it back. So I created the local profile instead and just entered my email address.

I also did a lot of cleanup using my PC:

I went to Google+ and cleaned up my profile info. I went to Google Contacts and deleted my contact record, then re-created it. The contact record connected to Google+ when I entered my email address.

I disabled contacts syncing for a bunch of apps on my phone, like Twitter and YouMail.

To get the Me profile to connect to Google+ again and pull my profile info, I went to Manage Apps -> All -> Google+ and hit the Clear cache and Clear data buttons. I opened up the Google+ app and connected my account. Then I went back to the Me profile to confirm that it worked.

share|improve this answer
add comment

Had the same issue. Open the Google+ app on your phone. Sign out of Google+ then sign back in again. Fixed it for me.

share|improve this answer
2  
Thanks! I tried all the methods above, and none of them works for me. But this works! –  WiSaGaN May 14 '13 at 12:13
add comment

Some of the steps provided by others are not needed. I had the same problem and did the following:

  1. Look at your (ME) in contacts and determine if you are linked to Google+ or Gmail.
  2. Open either G+ or GMail in a web browser based on answer #1
  3. If Gmail - Open Contacts and fix the information
  4. If Google+ - Open your profile and fix the information
  5. On your phone (Mine is Galaxy3s (4.0 ICS)) and Settings->Application Manager->Gmail or Google+-> Click Clear Data then Click Clear Cache.
  6. Then go to Settings->Accounts and sync->Then click Sync All

And that was it. The phone was holding onto old data that was deleted on the web and it needed to be sync'd from scratch.

share|improve this answer
add comment

I scoured the internet and found that the "ME" profile was actually related to my MAPS application. I went to settings > applications > MAPS > uninstall updates and this cleared my "ME" profile. Hope that helps.

share|improve this answer
add comment

Have you taken a look at your Google contacts data? I believe what you see in Android is actually a combination of data coming from a few different sources, so you likely need to fix it upstream. At least for me, the data I see in my "me" contact coincides with what I see for myself on google.com/contacts.

share|improve this answer
    
Yes. I looked in Google Contacts, and these extra email addresses (which technically once belonged to me, but I don't want in my contact info) are nowhere to be found there. –  Josh Dec 22 '11 at 17:22
    
As Will said: the me contact is a mashup getting information from different interlinked accounts. –  Marius Butuc Dec 22 '11 at 19:44
    
I'd just like to edit it directly, or be able to see its sources of information, since I can't find the "accounts" where these certain email addresses are being pulled from. –  Josh Dec 23 '11 at 15:59
add comment

It's definitely connected to your Google+ account. I had a blank "me" profile before logging in to Google+, then the fields began to populate after logging in. Still working on linking the Google+ to my contact in Google Contacts

share|improve this answer
    
I'm sure it is at least partially connected to your Google+ account, but my ME contact still contains email addresses that have never been listed in my G+ profile. –  Josh Feb 6 '12 at 21:55
add comment

I wasted many hours trying to edit the ME account. Finally, I just deleted it, and then reentered all the information correctly. It is absurd that there is no help about this matter, or that one cannot edit this contact, which would save a huge amount of time.

share|improve this answer
add comment

I finally managed to rectify this problem.

The problem persists if you have more than one gmail account in your smartphone and all of them linked with Google+. So, this is what I did, step by step:

  1. Login to your PRIMARY gmail acount from your desktop and view your Google Contacts.
  2. Search within Google Contacts your PRIMARY gmail address. Your own contact should appear, so just add in your mobile phone number. Save this information if Google Contacts hasn't done it automatically.
  3. Next, from your phone, go to the Google+ app and sign out from ALL of the accounts that you have signed into.
  4. Lastly, sign back in using your PRIMARY gmail account. By this, 'ME' or 'Myself' from your phone's contact list should have the correct info.
share|improve this answer
add comment

Check the "Accounts and Import" tab under Settings in your (desktop) Gmail. You may have some addresses listed there that are no longer current.

share|improve this answer
    
Been there, done that. These email addresses aren't there. –  Josh Jan 2 '12 at 12:20
    
And the main question is "How do I edit the ME contact, including such things as deleting email addresses?", not necessarily asking where the addresses came from. –  Josh Jan 2 '12 at 12:34
    
@Josh - you didn't mention that you'd checked Gmail settings, and it might be helpful to someone else that finds this via a Google search. –  TomG Jan 2 '12 at 14:58
add comment

Edit your contact on gmail contact first (using your PC) and then Uninstall google+ from your GT and run it again. Open profile from google+ application and it will lead you to choose which account you will use for google+, select don't sync when it ask to sync google+.

share|improve this answer
add comment

Click open contacts. When contacts are open hit menu, then more and click my profile and then you can edit delete or what ever you want to do. Hope this helps.

share|improve this answer
    
Yes, this is what I'm doing. It doesn't allow me to add or delete email addresses from the list from this view. –  Josh Jan 2 '12 at 2:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.