Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I added a second Google account to my Dell Streak 5 running 2.2 and when I attempt to download an app (either paid or free) through the Market I get this error:

<App Name> could not be downloaded due to an error. (-101)

Downloading apps through the primary account on the device works just fine. I've tried downloading over both data and Wi-Fi as well as removing and re-adding the secondary account and clearing the Market data, with no luck. I'm using the 3.4.4 Market though this also occurs with the 3.1.3 Market. Also of note is that the device doesn't show up in the web Market — it only lists my Vibrant.

How can I fix this?

share|improve this question
    
I think you'd get a chuckle from this post: Unable to install or update apps via market –  geffchang Jan 2 '12 at 11:57
add comment

4 Answers 4

up vote 1 down vote accepted

Have you tried removing and adding both account? Or adding secondary account as primary account. Making secondary account primary may not be what you want but its worth a try.

share|improve this answer
    
A wipe and re-adding the accounts in the same way worked. Guess I'll never know what happened. Accepting since yours was first and would solve the problem. –  Matthew Read Jan 8 '12 at 5:10
add comment

have you tried erasing all user data on your device, then re-adding both accounts? To do this, go to Settings - Security - Wipe Data.

share|improve this answer
    
Not yet; I'll side-load Titanium to backup and then try it. –  Matthew Read Jan 3 '12 at 15:06
    
Ok, please get back to me if it works! –  Liam W Jan 3 '12 at 16:53
    
A wipe and re-adding the accounts in the same way worked. Guess I'll never know what happened. Bountying since your answer is more direct. –  Matthew Read Jan 8 '12 at 5:10
add comment

Just had the same issue on my Asus Transformer Prime tablet. Fixed by updating the timezone to the proper one, Settings -> Date & time.

share|improve this answer
1  
Interesting. I don't know whether the timezone was correct for me but I'll test this out. –  Matthew Read Mar 15 '12 at 19:17
add comment

Just master reset device. It work for me with error - 101. It will erase everything but it fix the error

share|improve this answer
1  
Overkill.​​​​​​ –  Matthew Read Mar 11 '13 at 21:26
add comment

protected by Matthew Read Mar 11 '13 at 21:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.