Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I try to connect my Galaxy S2 device to my computer via USB, I get an error saying that the device has malfunctioned and is unrecognized. It appears as "Unknown device" in device manager.

I'm using Windows 7.

share|improve this question
add comment

10 Answers

I tried this from my Samsung Galaxy Ace Plus and it worked:

from ur mobile, click MENU > SETTINGS > APPLICATIONS > DEVELOPMENT

UNTICK USB debugging, Stay Awake, Allow mock locations

insert USB cable from mobile to PC/laptop > "Enable USB debugging" > OK

drag down the the USB icon from the upper left part of the screen

tap on "Connect USB" > "Connect to USB storage"

then, automatically, ur PC/laptop will now detect ung mobile/sd device

from the laptop/PC, select "Open folder to view files"

there, u'll see MEMORY CARD storage and MOBILE storage as "Removable Disk..." (mine is G)

YOU should now be able to transfer files from PC>mobile and vice versa

Hope this helps.

share|improve this answer
add comment

In addition to what the others have already answered, if you just want to access the files on the phone's storage and SD card, you can just mount the file system.

Unplug the USB cable, then Settings > Wireless and network > USB utilities > Connect storage to PC

share|improve this answer
add comment

try to key in this in dialer

*#7284#

it has 4 option there..

UART MODEM PDA USB MODEM PDA

For usb. select the PDA.if it already selected to PDA. reselect it by select MODEM and then PDA again.. Only change the USB setting.. andthen press back. try reconnect to kies again.. hope it helps..

share|improve this answer
add comment

This problem might be because you dont have the neceasary drivers. Make sure you have the USB debugging mode ON for your device. Then use Samsung Kies, a software like itunes, to detect your device.

share|improve this answer
    
Downloaded these drivers: mediafire.com/?8jq83u3xs6w8jou and enabled debugging mode and still no go –  Lockhead Jan 2 '12 at 16:11
    
You don't need to download those drivers. Just download Samsung Kies. It has the inbuilt drivers necessary to detect your phone. –  Kiran Jan 2 '12 at 17:08
    
I reinstalled Kies twice and my phone still doesn't get recognized at all. Kies doesn't even know that it's plugged in, and I'm getting the same unrecognized device problem. –  Lockhead Jan 2 '12 at 21:04
3  
As far as i know, there are two more things you can do. One is to check whether the USB mode is set to Samsung Kies when you connect your device to the PC. Only then, Kies will detect your device. If you have already tried this, the last option is to take your phone to a service center and have them check it for you. –  Kiran Jan 3 '12 at 4:38
    
Yes, I have tried that. So I took my phone to a service center, and now all I have left to do is wait. –  Lockhead Jan 4 '12 at 18:46
show 1 more comment

Hey you can try to solve this in two ways either you can download Samsung Kies and using that you can connect your phone , or if not by that way then u can check in your phone that is your USB Debugging On its in settings Option > Application > Development see that is it checked or not, if its checked then it means its on..

You Can also Download PDA NET and install in your PC thats also one of the way if you dont want to install Samsung Kies

share|improve this answer
add comment

Are you sure that USB Debugging mode is on?

Under Settings > Applications > Development you should see an option for USB Debugging -- if that isn't checked you won't be able to mount your phone.

share|improve this answer
    
Tried that already. –  Lockhead Jan 4 '12 at 18:45
add comment

I've had the same problem. I was so annoyed that I did a factory reset. It clears all your data, but it also solved my issue.

share|improve this answer
    
without any troubleshooting first? –  Mr. Buster Mar 12 '13 at 17:54
add comment

When windows sees it as "the device has malfunctioned" it is a different issue than when it says "drivers were not installed, your device may not work properly. " If it says "malfunction" it is a problem with the usb hardware connections themselves, albeit the cable end or the device port. Try using some electrical contact cleaner and a soft tooth brush and the clear the port with a compressed air duster can. Just spray a little of the cleaner on the brush and gently clean your port and/or cable. Then spray area just enough to dry with air duster. Worked well for me. If you take it to a service shop they will do it for you for a minimal fee.

share|improve this answer
add comment

I had the same prob as my S3 is not deteced on my MAC , but it is very easy to solve:

  1. Connect your S2 to your PC using a datacable
  2. Now in your phone, go to Settings→More→USB Utilities
  3. Turn on USB mass storage button.

It works.

share|improve this answer
add comment

Isn't it so strange that on some computer config it is not a problem??? In many cases a third party software is the badass ( e.g. firewall, antivirus apps.) Always try on another machine before you go back to the shop:-)

share|improve this answer
    
not a very good answer.... re-edit to improve your answer... –  t0mm13b Dec 25 '12 at 22:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.