Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Whether I enter a URL directly, or whether another app invokes my browser (e.g. Google News & Weather when clicking on a headline), the browser pauses for a while (maybe half a minute, maybe several minutes) before it even begins to load a page.

All that I see during the pause is the part of the URL that fits, followed by an ellipsis, followed by the refresh icon, and the bookmark icon. The page is blank white. Touching the refresh icon does nothing but highlight it very briefly. Eventually the refresh icon changes to an animated dotted circle, and the page starts to load, but it can take many minutes before the browser "wakes up" and starts to load the page.

What's going on here?

This happens on two different models of the same phone that were bought at the same time, less than a month ago:

LG MyTouch on T-Mobile (model LG-C800)
Android 2.3.4
software version LGC800-V10d-SEP-19-2011
share|improve this question
    
You could check if it's the DNS resolution taking time by entering the ipaddress of a page directly. –  tidbeck Jan 7 '12 at 12:25

1 Answer 1

I've had that problem intermittently. I started using SetDNS back when the Market would crawl on Wifi, but now I find that simply switching my DNS servers when the web gets laggy usually fixes the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.