Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

For some reason, after I changed my device's battery. It just keeps rebooting and here's a LogCat of the error:

E/JavaBinder( 1305): *** Uncaught remote exception!  (Exceptions are not yet supported across processes.)  
E/JavaBinder( 1305): java.lang.ArrayIndexOutOfBoundsException: length=5; index=6  
E/JavaBinder( 1305):    at com.android.internal.os.BatteryStatsImpl.updateAllPhoneStateLocked(BatteryStatsImpl.java:1907)  
E/JavaBinder( 1305):    at com.android.internal.os.BatteryStatsImpl.notePhoneSignalStrengthLocked(BatteryStatsImpl.java:1937)  
E/JavaBinder( 1305):    at com.android.server.am.BatteryStatsService.notePhoneSignalStrength(BatteryStatsService.java:211)  
E/JavaBinder( 1305):    at com.android.server.TelephonyRegistry.broadcastSignalStrengthChanged(TelephonyRegistry.java:564)  
E/JavaBinder( 1305):    at com.android.server.TelephonyRegistry.notifySignalStrength(TelephonyRegistry.java:325)  
E/JavaBinder( 1305):    at com.android.internal.telephony.ITelephonyRegistry$Stub.onTransact(ITelephonyRegistry.java:95)  
E/JavaBinder( 1305):    at android.os.Binder.execTransact(Binder.java:338)  
E/JavaBinder( 1305):    at dalvik.system.NativeStart.run(Native Method)
share|improve this question

migrated from stackoverflow.com Jan 8 '12 at 3:34

This question came from our site for professional and enthusiast programmers.

    
Have you downloaded any performance app recently? –  thinksteep Jan 6 '12 at 18:46
    
No, I used to use the one in CM7 but I changed the ROM and now I don't use anything. Although this problem did also exist in CM7. –  user1134955 Jan 6 '12 at 18:49
    
Kill your batterstatsservice from running services. There is something wrong with it. –  thinksteep Jan 6 '12 at 18:49
    
It seems the battery you recently installed is not supportive for the device. –  thinksteep Jan 6 '12 at 18:51
1  
I uninstalled the app and switched to the battery that shipped with my device, and i'm still getting reboots. –  user1134955 Jan 6 '12 at 19:03
show 5 more comments

1 Answer

Almost everything in the full logcat is an error. I would suggest going a full wipe of Data & Cache and then reinstall your custom ROM. There is no way to know for sure that the part you posted in the original question is the one causing the reboot. They system rebooting may not allow the actual app that is causing it to write to the logcat.

You are hiving errors in everything from Telephony to the Installer. It sounds like there is something in the system that is causing a problem, See if clearing the Data and Cache fixes it, especially if you never cleared it before switching from one ROM to another.


Based on your comment that you have tried clearing the cache and data, i would suggest then to try and clear the battery stats. This can be done in Clockwork Recovery, I think there are apps in the market that can do it too, but I dont know if you can get to those as your device is rebooting all the time.

If that doesn't solve it, I would try a different battery because if you have cleared the cache and data and also tried multiple ROMs and still have the same problem, then it sounds like faulty hardware.

share|improve this answer
    
Always clear my cache and data, tried numurous ROMs and still, no result. –  Hussam Jan 9 '12 at 17:30
    
if you have tried multiple roms, and cleared cache and data on them all, you may have faulty hardware. one other suggestion, try clearing the battery stats. If that doesn't do any thing, then try a different battery. –  Ryan Conrad Jan 9 '12 at 17:33
    
Tried clearing battery stats and tried the battery that shipped with my device. The problem goes when I use the other battery, but if I reboot the device, then the problem comes back. Also, I noticed that if I boot without the SD card, the problem goes away completely. –  Hussam Jan 9 '12 at 20:06
    
do you have any apps installed to the sdcard? –  Ryan Conrad Jan 9 '12 at 21:31
    
Yes, I do have apps on my sd card. –  Hussam Jan 10 '12 at 19:20
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.