Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have an android 2.2 phone. The other day, I was using a wi-fi connection on my phone and had it tethered to my laptop. For whatever reason, the wi-fi connection dropped and my phone starting using my phones 3g connection to continue the internet connection tethered to my laptop...

Is it possible to stop this from happening? i.e. if the wireless connection drops, don't use the 3g connection automatically?

share|improve this question

3 Answers 3

up vote 5 down vote accepted

If you have no reason to why the wifi drops, you might try changing the wifi sleep policy. The wifi sleep policy handles when or if the wifi connection shall switch to mobile data. If this option is set to the default value, When screen turns off, wifi connection automatically switches off when the phone has been idle for a while. You can try setting this to Never, which will keep the connection on, even when the phone is not used.

To change this setting, navigate to Settings -> Wireless & networks -> Wi-Fi settings -> [Menu] -> Advanced -> Wi-Fi sleep policy.

share|improve this answer
    
What does Never when plugged in mean? –  oshirowanen Jan 20 '12 at 11:56
    
It means that the default policy (When screen turns off) is used when the device is on battery, and when the device is plugged into power Wi-Fi never go to sleep. –  ajgarn Jan 20 '12 at 13:48
    
So if I have the phone plugged into a usb powered port, where the phone gets charged. If I then enable wifi on the phone, and tethering to the laptop via the same usb port. Will this work? i.e. will wifi never turn off if I have the never when plugged in selected? I'll give it a try asap anyway. –  oshirowanen Jan 20 '12 at 16:15
    
Yes, I think this will work! Give it a try! –  ajgarn Jan 21 '12 at 13:11

Turn off mobile data usage. Go to Settings->Wireless and networks->Mobile network(you should uncheck this). Some manufacturers may have a widget for this, such as HTC did for my Incredible(v1).

share|improve this answer

Try enabling airplane mode. It will shut down all the radios on your device - cell, wifi, bluetooth. Then try explicitly turning the wifi back on. Not all devices support this - driver issues, I think - but in many you will wind up with the cell radio disabled and the wifi on.

share|improve this answer
    
Thanks for the suggestion, I will give this a try asap. –  oshirowanen Jan 16 '12 at 16:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.