Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

when connecting my Samsung Galaxy tab 10.1 (USB debugging off) to my PC running Ubuntu 10.10 the device seems to be mounted properly, but I can't transfer any file (I always get "Error creating directory: -1: Unspecified error").

I googled the issue, installed mtp-tools and mtpfs, tried several recommended methods, but I still can't use my tab as a mass storage device.

Anybody can help?

share|improve this question
    
I think i have read that you have to have usb debugging on for it to work. –  Ryan Conrad Jan 16 '12 at 16:44
    
Several devices are like that, unfortunately. –  Matthew Read Jan 16 '12 at 16:59
    
No fix? I won't be able to transfer file from Ubuntu? It sounds like a joke... –  jul Jan 16 '12 at 17:05
1  
Did you try turning on USB debugging? –  Matthew Read Feb 10 '12 at 3:25
    
I think you'll get better help at askubuntu.com –  roxan Feb 10 '12 at 4:06

7 Answers 7

Just bought a Galaxy Note 10.1, and ran through same problem to transfer file through USB with my Ubuntu 12.04 PC.
Now, it seems that using 'connect as a camera' is smoother... No need of any other software.
Go to Settings / Developer options, and check 'USB debugging'
Then open the main menu (where you get the notifications) and tap on "Connected as..." to open the 'Storage settings/USB PC connection' menu (can figure out how to access it another way): 2 options 'Media device (MTP)' and 'Camera (PTP)'. I checked the Camera(PTP).
Then connect the device to the PC, cancel all messages that may appear on the PC, and normally the device should mount automatically: 2 icons should appear on the desktop: 1 is the main card, the other the extension card.
Now you can copy and past files from the PC to the device cards via Nuatilus like for any other device.
BUT...

  1. you do not have access to the files on the cards: ie,the directories appear empty (if they appear at all). So you may need to shuffle the files around afterwards on the device directly to re-arrange the locations etc... Appart from that, drag and drop files on the extSD card does work: the files are copied, no pb.
    You do have access to the files and directories you just copied though.

  2. Some characters seems to be forbidden in the names of files and directories that you copy. Do not use: " or : or ? and perhaps some others. the . - _ and ' are ok. But having a forbidden character in the file or directory name causes an error as reported in the original post :"Error creating directory: -1: Unspecified error" if pb is in the name of the directory you want to copy, or "Error copying file xxxx: -1: Unspecified error" if it's in the file name.

share|improve this answer

I have a Galaxy S2 and I resolved a similar problem using the phone just as a mass storage device (and not using MTP), following this tutorial from askubuntu (it worked nicely):

  • go to the settings
  • under Wireless and network click on "More"
  • select USB utilities
  • click the "Connect storage to PC"

Now you can plug in the USB cable and use USB mass storage.

On more modern versions of Android, you may need to click the "More…" item in settings. This contains the "USB Utilities" item, mentioned above.

share|improve this answer
    
Answers where there is no useful information except what can be found by following a link are not really answers; answers should be able to stand on their own. Please copy the relevant information into your answer (but by all means give credit to the source). –  Al E. Nov 30 '12 at 15:04
    
Is it ok now? :) –  franzlorenzon Nov 30 '12 at 15:10
1  
Absolutely. On behalf of future readers: Thanks. –  Al E. Nov 30 '12 at 15:11
    
That's the way to do it, but the real problem with Galaxy Tab seems to that this option is absent in the settings -- very confusing! According to the answers above, USB debugging should be turned on for it to appear. –  imz -- Ivan Zakharyaschev Jul 11 '13 at 10:27

I did what @Logos suggested. If you are looking for solution for your Galaxy Tab (tablet, not Galaxy phone), then upon plugging usb data cable to your linux computer you will see a usb connection icon. Tap on notification aera, then on usb connection, then tap on check-box that is non-MTP connection option. Then you will see your Galaxy tab's SD card mounted on your desktop. If you browse folders - you will find them empty, content is not shown. Just transfer your files where you want them to be. The opposite direction is not working, I guess.

share|improve this answer
    
Speed of transfer is... wow... blazing slow (( –  vlad Aug 28 '12 at 4:22

Ubuntu 10 requires manual editing of your udev config in order to recognize an Android device's SD card.

As root create the text file "/etc/udev/rules.d/51-android.rules” and add this line for a Samsung device:

SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"

Save the file and exit the editor, then set the permissions of the file and restart the udev system:

$ sudo chmod a+rx /etc/udev/rules.d/51-android.rules
$ sudo restart udev
udev start/running, process xxxx

If that doesn't work, you can also install an app for file xfring as other answers have recommended. Personally I favour Samba Filesharing.

share|improve this answer

Install SSHDroid on your phone and mount it on your Linux box using sshfs. Even if a wifi network is unavailable, you can still manage a transfer just by setting up wifi tethering on your phone (this will even work without a data connection, say when you're travelling).

Connect your laptop to the wifi tether and then turn on SSHDroid. After that it's just like copying to a server. You can use a command like:

scp /home/daniel/Music/* 192.168.48.1:/mnt/sdcard/Music/

Or even mount that remote sftp server to a local path. Just google for sshfs fstab. Just note that the ip mentioned here will likely be different for you.

Note that data will move between your laptop and your phone on the local network, not using up your mobile data connection (if you even have access to one), so there's no need to worry about data fees.

share|improve this answer

The best hassle free way to transfer files between Ubuntu and your device is by using and ftp client like FileZilla on Ubuntu and Software Data Cable for your android device. You can then transfer files via FTP. Works for me. Hope it helps.

share|improve this answer

Use Kies. It transfers files between devices in an easy way, using a web browser. Awesome!

share|improve this answer
1  
Kies isn't available for Ubuntu. –  Matthew Read Feb 10 '12 at 3:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.