Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I purchased a Galaxy Mini with 2.2.1 a few days ago and I can connect to my home network (the wireless icon appears) but I can't surf on the Internet. I verified it got an IP correctly and tried many suggestions but no luck. It worked once at home and on a friend's network.

My router is a wireless-n Linksys.

share|improve this question
up vote 3 down vote accepted

This sounds more like inconsistent wifi settings.

Since your phone shows its connected, try to visit your router's web interface through the phone to see if its connected properly. (note that please use stock browser and no proxies for now) If this doesn't work, most likely its the problem with wrong password or security mode like WEP/WPA.

If the above works, then I suspect you to have a DNS problem. A rooted phone can let you custom-set the DNS on your phone. Try to set it to Google's DNS. Just to confirm if its a DNS problem, try entering an IP address of a website rather than the domain name.

share|improve this answer
it's solved :), just remove DNS from router setting and enjoy ^_^ – wisdom Jan 20 '12 at 14:29

A few things to try:

  • Reboot your device
  • Change the router to use 802.11b/g instead of 802.11n
  • Change the router channel (to 1, 6, or 11 if using North American channels)
  • Change the security from WEP to WPA or vice-versa
  • Ensure you have no MAC filtering or firewall rules on the router
  • Switch the router from using the 5.0 GHz band to the 2.4 GHz band, or vice-versa
  • Other suggestions posted in answer to Windows laptop works with Wi-Fi AP, phone claims it is connected but can't access Internet
share|improve this answer
unfortunately, nothing helps :'( there any hope ?? – wisdom Jan 19 '12 at 23:22

I have been using Galaxy Mini for the last 2 years. WiFi is working with normal network. But in our company, advanced WiFi mobile is not responding. After Googling, I found out this phone does not have 'direct WiFi' options like higher-end phones (eg. Galaxy SII).

I suggest you change the phone!

share|improve this answer
I don't quite understand why Direct WiFi is required for connecting to Internet via WiFi? Direct WiFi is required only to connect to other WiFi devices (other than access point/router) to share data like files etc. – Narayanan Mar 7 '13 at 5:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.