Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I originally posted this in stackoverflow and was told to ask this here.

I downloaded a compiled lynx binary from xda and everytime I start lynx it tells me that it is unable to connect to remote host. I changed the lynx.cfg to use localhost and that loads, but when I enter a URL, nothing. I tried it with 3G, 2G, and WiFi, and no luck. What am I doing wrong?

share|improve this question
Firstly why? I can remeber using Lynx back in the mid-90s, not something I'd ever want to go back to! Secondly, a few of the people on that XDA thread also mention that exact error, have you tried asking there, the user that created the Lynx binary seems to be trying to help with the problem but no one's taking him up on it. –  GAThrawn Jan 25 '12 at 11:34
I am using vim in Terminal IDE and need to copy some URLs. I am unable to copy the URLs from android into Terminal IDE. So my only other alternative is to use lynx, links, or elinks. I found this lynx, but if you have a better option, I am all ears. Also, my phone is not rooted. I tried registering with xda but I need to answer other people's questions before I can reply in that thread, and seeing as I do not know anything about this stuff, that option is sadly unavailable to me. So my options are learn how to copy into Terminal IDE or get a bash based browser. –  thequerist Jan 25 '12 at 21:00
"copy some URLs"? Do you mean, paste the literal URL ("foo://bar/etc") into the terminal? If so, just select and copy the URL in some other app, and use the menu in TIDE to paste them. –  Julian Fondren Feb 21 '12 at 3:32
Yes, the developer added that feature. Works great! –  thequerist Feb 21 '12 at 4:36

3 Answers 3

up vote -1 down vote accepted

It is possible for you to interact directly with the Android clipboard (read from/write to) from within the shell.

Details found here.

share|improve this answer
How does this answer the question? –  Al E. Aug 12 '13 at 16:53

The problem is that DNS binding suport is different on Android, so Lynx and wget, etc, if statically compiled by standard gcc under linux, will not be able to lookup the domain name, but would work with a numerical ip address. You can see that problem in many of the busybox implementations for android.

There is some discussion of this at kevinboone.net/kbox2.html

share|improve this answer

You may wish to check out Lynx Browser at google play.

share|improve this answer
I think the OP is interested in getting the actual Lynx browser to work, not some dodgy app that illicitly uses the same name for an unrelated product. –  Dan Hulme Aug 12 '13 at 8:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.