Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Verizon Motorola Droid Pro (Android 2.3.3), and a persistent aggravation with the browser application.

Whenever typing in an input field and using a dash - that is adjacent to its preceding character, the next character I type is placed before the dash, and then the cursor placed before the dash. That is, assuming I'm trying to type android-browser:

  1. I type android- At that moment, the cursor is correctly after the dash.
  2. I type b The b is placed before the dash, and the cursor is now located after the b, before the dash. So if I kept typing I would end up with androidbrowser- with the cursor still before the dash.

This only happens in the Browser application, when I am inserting a dash that is adjacent to its preceding text. So if I were trying to type android - browser it would work fine. In order to get around this, I have to type android- and then manually move the cursor (although the end location is exactly where it already is at the end of the text!)

This happened before the Android system update a few months ago too, and I had hoped that the update would fix it... but, no dice!

I've considered that an alternate browser could be a solution, but I'd prefer to stick with the Android browser, I think.

share|improve this question
3  
Have you tried a different keyboard app? Even though Droid Pro has a physical keyboard, alternate input methods may change its behavior. –  Chahk Jan 25 '12 at 14:05
2  
I agree with Chahk, this sounds like an issue with the keyboard app that handles the software side, like auto-complete or spell corrections. Not to mention this device runs BLUR which has always been rather buggy. –  Ryan Conrad Jan 25 '12 at 14:36
    
@Chahk I'll look at that option some! –  Andrew Barber Jan 25 '12 at 16:55

1 Answer 1

up vote 1 down vote accepted

It seems that, as noted in the comments, changing my keyboard app has solved this. I was having trouble with my default kb app going to 100% cpu when entering text lately, so that prompted me to try a new one, finally.

I have tried multiple times while typing this answer to get the behavior to occur again, and it won't. Yippee!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.