Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Android 2.3.4.

I have noticed that even When I turn off Wi-Fi, I still keep getting notifications, like - Gmail, Gtalk and Google+ notifications. If I open the said App then it says that it is not connected to internet.

So, my hypothesis is that maybe when I disable Wi-Fi, Android does not terminate currently established connections. It only denies new connections. But this does not explain why in this case the notifications are usually delayed, sometimes, by few hours or a full day.

What is happening and how do I actually disable the Wi-Fi?

PS: I use the "Status Switch" widget to turn/off the Wi-Fi.

UPDATE: the phone doesn't have a data plan, so data isn't coming in that way.

share|improve this question
Turning off your wifi actually disables the wifi radio hardware, so it can't be that it's maintaining existing connections unless you have an extremely unusual build of Android. – Logos Jan 27 '12 at 14:12
Hmm.. I am not sure, but it does keeps on sending notifications. More weird is that sometimes I get the notifications after many hours. I have Sony Ericssion Xperia. Maybe it is isolated to Sony phones. – AppleGrew Jan 27 '12 at 14:15
my best guess currently is that "Status Switch" does not work properly on your phone; check that the Wifi is really disabled through the Settings app. – Lie Ryan Jan 27 '12 at 17:26
Yes there it shows up unchecked. – AppleGrew Jan 27 '12 at 17:54
Are you sure, your 2G/3G/4G connection is not running? Put a random string in your APN... – Evil Angel Feb 26 '12 at 17:58

I belive it is because you gained the data during the period Wi-Fi was activated, so when you swithced off your Wi-Fi, there was still some unread data you hadn't seen (in the form of mail and G+ notifications). Also I recomed, if you are seriously worried about this, and it perseveres, to turn off Wi-Fi via wireless communications in the settings app.

share|improve this answer
All the data, e.g. notifications were generated after I switched off the Wifi from Settings. I seems this is a Sony Ericsson build specific issue (or feature?). I have noticed that even after Wifi is disabled it turns itself on briefly on some seemingly random time. – AppleGrew Apr 8 '12 at 5:16

If you turn off Wi-Fi, but you have a data plan with your carrier, you'll still be accessing the internet using your cellular mobile radio.

Opening the app and having it say that it is not connected to the internet could thus be because you have poor signal, or you haven't used your phone in a while and it's been auto-disconnected from the mobile network to save battery/bandwidth by either the phone or your carrier.

You can use Airplane Mode to turn off both cellular and Wi-Fi radios.

share|improve this answer
My Data traffic too is disabled. If my phone uses carrier data then that would reflect in my bill. My carrier charges too much for data usage. Also, I have strong network signal. – AppleGrew Jan 27 '12 at 10:45
You should definitely mention that in your question then. – Logos Jan 27 '12 at 14:11
Oops. Sorry about that. – AppleGrew Jan 27 '12 at 14:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.