Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Good afternoon all,

I was originally using a GSM iPhone and I've switched to an android Samsung Galaxy Ace S5830L. I've got some problems connecting to the internet and was wondering if someone could help me resolve the issue.

These are the steps I took from Settings >> Wireless and networks >> Mobile networks >> Network operators:

enter image description here

enter image description here

enter image description here

enter image description here

I've selected SGP-M1-GSM and it says "Registered on network" but I still can't seem to connect to the internet.

enter image description here

What do I have to do to enable internet connection?

I'm currently using v2.3.4 if that matters.

share|improve this question
add comment

1 Answer

I am not sure if this would work, but worth a try. Some mobile phones and some cell phone service providers require the use of APN. Contact your cell phone service provider for the APN.

share|improve this answer
    
Heys cool it's working now (instructions from unlockit.co.nz/mobilesettings/settings.php?id=220) but it seems to be really slow, like 1 minute per page load. Do you know what may be the problem ? –  Pacerier Jan 30 '12 at 14:51
    
@Pacerier That sounds more like a network problem than an Android problem. –  Matthew Read Jan 30 '12 at 18:08
    
@MatthewRead But its slow yesterday and its still slow today.. (I don't get this problem on the iphone) is it possible that I have my settings set wrongly? Like do I have to turn off/on anything? –  Pacerier Jan 31 '12 at 7:54
    
Not sure but see if caching helps. –  Neel Mehta Jan 31 '12 at 11:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.