Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Google Books Android crashes on loading.

Is there a workaround to stop this, while I wait for the developers to fix?

The application Books (process has stopped unexpectedly. Please try again.

This happens every time (trying again won't help).

Restart of the phone and uninstall re-install of the app doesn't help either.

Apparently, there is a known issue whereby it will crash if it has no books (wouldn't that be most people to begin with!?)

But their remedy instructions are vague - just open a free ebook - but from what? A browser? Will this interact with Google Books to solve the problem? I visited the book store and downloaded an ebook but this just went to the Downloads folder so not sure how this can help.

I also tried copying an ebook from the Download folder to data\\files and running the Google Books app but this doesn't work - i.e. the crash still happens.

share|improve this question
And is this still happening? If it was a known bug I suspect they've probably fixed it by now. – Al E. Jul 3 '12 at 19:39
+1 Yes this has righted itself now thanks. – therobyouknow Jul 3 '12 at 22:01
I've been having this problem for a few months. Time doesn't seem to be doing the trick for me :( – Kris C Jul 3 '13 at 14:26
up vote 0 down vote accepted

The solution is time; an update to this app fixes this bug.

share|improve this answer

To get around this problem is very simple. Do these actions:

  1. Use your web browse on the Android device and go to website ""
  2. Pick and download any sample book (click on Get Sample)

Once you have saved a sample book you will be able to successfully launch the Books application without the process error.

Good luck

share|improve this answer
Yup, your answer is exactly the same as their solution which doesn't work for me at the moment, as I have explained. – therobyouknow Feb 19 '12 at 2:34

I had the same problem, and fixed it by opening a preview of a different book first. After that, I could open the other books too. Make sure you open it from within the Play Store app, and not from Google Books.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.