Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Google Voice app has the option "Receive text messages" with two choices:

  • Also via the messaging app
  • Only via the Google Voice app

If I choose the first option, I will still get the text messages even if I'm not on Wi-Fi. It will also send them as regular text messages if I am on Wi-Fi, wasting money.

If I choose the second option, I won't get the messages if I'm not on Wi-Fi.

Is there a way to get the messages forwarded to regular text only if the Google Voice app doesn't get them?

share|improve this question
add comment

2 Answers 2

I think you might be misunderstanding how GV handles messages.

Receiving Messages:

When someone sends an SMS to your GV number it is received by Google and placed in your GV inbox - the setting you mention doesn't change that functionality, so either way you choose to have the app configured your GV SMS messages will still be available in the GV app (and, of course, your GV inbox in the cloud).

If you don't have a data connection then you'll get GV SMS messages delivered to your phone as soon as you have a data/wifi connection and your inbox is synced. Even if you set the GV app to Receive text messages > Also via the messaging app you'll still only receive the messages when your GV inbox is synced - you'll just also get the messages duplicated in your default SMS app.

Confusingly, you can also have your GV inbox setup to send SMS copy of the messages your GV number receives to your mobile's number using your carrier's SMS system. This isn't necessary if you have the GV app on your Android phone and want to use data/wifi to receive messages. I advise turning this setting off in your GV inbox web interface: Settings > Phones > [Mobile Phone] then uncheck Receive text messages on this phone. You will still receive texts sent to your GV number on your phone, just via the GV app using data/wifi and not your default SMS app using your carrier's SMS.

Sending Messages:

First, the easier stuff:

  • To send a text message from your GV number using data/wifi make sure to use the GV app on your phone to compose and send messages.
  • To send a text message from your mobile number using your carrier's SMS make sure to use the default SMS app on your phone.

Now, the harder stuff:

If you have Receive text messages > Also via the messaging app set in the GV app, you'll see the same text messages in both your GV app and your default SMS app. Please note that this is a slightly different condition than having Receive text messages on this phone set for your mobile phone in your GV inbox, even though the end result looks the same. Given this condition:

  • If you reply using the GV app you will reply from your GV number over data/wifi.
  • If you reply using the default SMS app you will reply from your GV number over your carrier's SMS (this is just as if GV sent your mobile an SMS copy and you replied to it on a non-smart phone).

I suspect some combination of the above settings and usage scenarios is causing your problem, and that by simply changing some settings or your habits (or both) will result in the behavior you're looking for.

EDIT: To help with confusion I've drawn a quick flowchart:

Google Voice SMS flowchart

share|improve this answer
    
Ah. What I want is for GV to send the text to the phone app over the web, but if the phone app doesn't receive it (no data connection), then it should forward to SMS over the cell carrier. –  endolith Feb 10 '12 at 16:02
1  
AFAICT that kind of fail-over setting isn't available; it seems forwarding to SMS is either on or off. –  Mr. Buster Feb 10 '12 at 18:24
    
This is a fantastic answer. Thank you. –  Charlie Flowers Jul 22 '13 at 6:09
add comment

Just a note - I recently noticed that the GV app setting Receive text messages → Via the message app no longer duplicates the message locally on your phone as described in the original answer. Instead, it simply toggles the GV Inbox setting Receive text messages on this phone. I verified this by:

  1. enabling the feature via the web (GV Inbox)
  2. noting that it was enabled in the GV App settings
  3. selecting "Via the Google Voice App" from the GV App settings
  4. refreshing the GV Inbox webpage and noting the forwarding feature was now unselected.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.