Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I don't know if this is standard ICS behavior or if it's due to my Cyanogenmod based ROM, but every time I open the soft keyboard by clicking on a text box/area a notification appears in the notification drawer that says "Select input method." I don't mind seeing this notification one time, but I'm already using the input method I want and I'd like to disable the notification.

Is this standard behavior for Ice Cream Sandwich? Can it be disabled?

share|improve this question
    
Do you have an external keyboard paired/plugged in or anything of that sort? That's the only time I've seen it appear, personally. –  eldarerathis Feb 16 '12 at 18:38
    
No I don't. I'm using just my phone and nothing else, and there's no hardware keyboard on my particular phone (Droid Bionic) –  rushinge Feb 16 '12 at 18:46

12 Answers 12

up vote 21 down vote accepted

This is a standard 'feature' of ICS. Aside from the notification, changing input methods can be accomplished through the "language and input" section of the phone menu. If you disable and uninstall all keyboards except for one, so there is nothing else to switch to, the notification may disappear.

share|improve this answer
1  
Unfortunately, this is true. The only way to disable it is to run a custom ICS ROM that the ability to disable it (a few do). –  dymmeh Feb 16 '12 at 20:43
3  
Ha that's kinda lame. I guess I have my answer then. –  rushinge Feb 16 '12 at 21:02
3  
I'm not sure about stock ICS, but in CyanogenMod 9 there is a toggle that allows you to hide this notification. I will post this as a separate answer. –  Chahk Jun 7 '12 at 18:14
2  
I am using alternative keyboard and can't disable the default. Which means I have two I input methods. Thus I can't get rid of notification. Sucks... –  Sergiy Byelozyorov Nov 9 '12 at 20:23
1  
@SergiyByelozyorov You can not uncheck it, but you can disable by Settings ->Apps ->All ->Google Keyboard ->Disable ->OK –  András Mar 8 at 13:08

I'm not sure about stock ICS, but in CyanogenMod 9 & 10.2 you can disable this notification by going to "Settings -> Language & input" and de-selecting the "Selector notification" option just below the list of keyboards.

share|improve this answer
    
I'm using CM 11 and no longer have this option :( –  Ben Dec 27 '13 at 17:00
    
@Ben CM 11 is still a work in progress. Most of the CM 10.2 features are currently being forward-ported, and should eventually re-appear. Give it some time. –  Chahk Dec 27 '13 at 19:41
    
I confirm that CM11 does have this option now, and also most ROMs that are based on it. –  killogre Jun 15 at 13:45
    
This option is also present in Paranoid Android (4.6 BETA 1) –  Ruud Lenders 13 hours ago

Go into language settings and disable(uncheck) all of the other keyboards but the one you wish to use. go to applications settings, find the "all" tab, find the other stock keyboards and disable them. restart. worked for me.

share|improve this answer
    
This should definitely be marked as correct answer, IMO. On my stock ICS GNexus, I did this (while leaving my Google voice keyboard option enabled), and once I restarted, the icon no longer appears. Finally! –  Davek804 Jun 11 '12 at 3:03
    
Just a note, this doesn't seem to work with JB 4.2. :/ –  Cory Apr 25 '13 at 22:18
    
This seems to work perfectly fine on my Google Nexus 4 running Android 4.4.4. –  Amal Murali Jul 3 at 16:13

Yes it is standard behavior in ICS. This appears if you have more than one keyboard selected in the ICS keyboard & language settings page, which is always the case if you use a third party keyboard. Some custom roms (particularly CM9 and AOKP) allow you to disable it in their extra settings.

share|improve this answer

This is a feature in ICS and above. Its goal is to make it easy to switch input methods.

It only appears if you have more than one IME enabled. The sad thing is that if you use a non-stock keyboard this will always appear.

If you want to get rid of it simply go into

Settings -> Apps -> All (tab) 

and find the default keyboard(s). Open the entry and choose disable.

share|improve this answer
    
What's "the default keyboard" called? –  Steve Bennett Aug 19 at 7:11

Use Titanium Backup to backup, then uninstall "Android keyboard"

share|improve this answer

On Xperia devices you can disable this by disabling the "Smart Keyboard" option in
Settings->Xperia->Smart Keyboard.

share|improve this answer
    
Since when is the Motorola Droid Bionic (see comment of the asker) an Xperia device from Sony? –  Izzy Oct 10 '12 at 17:53

I very much agree with Peter. Here is/was my situation:

My GS III is running JB (4.1.1). When I looked in Settings > Language & input, under section Keyboards and input methods, Default was set to "Samsung keyboard". Immediately under that were listed three inputs, each with its own check box, in this order: Google voice typing, Samsung keyboard, Swype. The 2nd two had their check boxes selected and locked -- that is, you couldn't uncheck them.

I went into Settings > Application manager > ALL [tab] and disabled Swype followed by a restart. Without the restart, this input method would remain listed as noted above. Now, I no longer get the "Choose input method" notification because I have a single input enabled. :-)

share|improve this answer

Don't even mess with it. I got rid of all keyboards on my nexus 7 3G..... But could not delete Asus keyboard. Couldn't find it anywhere in /system or anywhere else. So I chose to delete google keyboard. Everything went to Chinese. Luckily I had a recovery backup.

Don't mess with it. Just let it float up top or whatever. Better the devil you know, then the devil you don't :)

share|improve this answer

If all else fails just disable the stock Google search (which automatically reactivates Google voice typing & therefore 'select input method') and use Google search from a downloaded app. Yahoo or Bing can also be replacement search engines.

share|improve this answer

Go to Settings > Language and Input and uncheck Google Voice Typing.

share|improve this answer

Renaming(delete ".apk") system/app/LatinimeGoogle.apk in Jelly Bean worked, you must have only 1 keyboard selected in settings.

share|improve this answer
2  
Or you could just, you know disable it from settings. –  Richard Borcsik Jul 5 '12 at 21:38
4  
Deleting a system apk without knowing what it does sounds like a good way to bork your phone. –  Al E. Jul 11 '12 at 16:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.