Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a tablet Aishuo A820, rooted. I tried to connecto to my GSM using PAN network with following commands:

pand --connect <device address>
ifconfig bnep0 up

and it worked. Then I had to stop testing and later I tried the same commands but it never works. logcat shows:

E/pand    ( 3255): Connect to <device address> failed. Connection timed out(110)

I can't understand what's different this time. I used sshDroid to connect over wifi both times. I tried under some consoles with wifi off - same result.

I tried to re-pair devices. Then I start pand again with --connect. The phone asks to give access. I answer allow and again timeout. I also tried "always allow" so the phone don't have to ask for permission. Nothing works! How did it work the first time?

share|improve this question

migrated from Feb 21 '12 at 2:01

This question came from our site for computer enthusiasts and power users.

I can't specifically answer your question, however, what I've found BT paring my Nexus 7 (JB 4.2) to my (rooted) Motorola Defy phone (Froyo 2.2.2), using standard setup panels, is similar. That is, it works the first time. On subsequent attempts, I see a 'connecting..' message then the BT Paring/Connection panel quickly returns to 'waiting for user input' with no connection.

In order to 'fix' it I have to reboot the Motorola (phone).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.