Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I tried flashing my Kindle Fire with a custom boot.img using this command:

$ fastboot -b 0x80000000 -i 0x1949 flash boot boot.img && fastboot reboot

sending 'boot' (3536 KB)...
OKAY [  0.889s]
writing 'boot'...
OKAY [  0.858s]
finished. total time: 1.746s
rebooting...
ERROR: usb_read failed with status e00002ed

finished. total time: 0.001s

$

but it always gets stuck in Fastboot Mode (requiring recovery mode). What's the correct command to get a successful flash?

share|improve this question
    
It looks like it's flashing fine, just failing to reboot. Do you get the same result if you execute the flash and reboot separately (like as completely independent commands)? –  eldarerathis Feb 25 '12 at 18:37
    
Yes, I've tried them separately, but it's the same result. The reboot itself doesn't actually fail as the error message above might suggest. The usb_read fails because the device has rebooted. –  superuser Feb 26 '12 at 7:21
    
Does a hot boot work? i.e. fastboot boot boot.img –  eldarerathis Feb 26 '12 at 16:54
    
That has the same result. :( –  superuser Feb 27 '12 at 4:35
    
Weird, I never had this much trouble flashing images in fastboot. Are you using the stock bootloader or FIREFIREFIRE? –  eldarerathis Feb 27 '12 at 13:52
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.