Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have working Wi-Fi connection. I can connect to any access point in range and I have no problems with passwords, etc.

But after some time (sometimes hours, sometimes days) my phone tries to connect to access point and it fails. In Wi-Fi settings I just have "Błąd" message which in English means "Error". Then I cannot connect to any network, I'm not eve able to scan available networks - Wi-Fi is totally dead.

When I reboot phone it starts to working normally again.

My phone specs:

Samsung Galaxy 5
GT-I5500
Android 2.2 - FROYO.XWJQ3
I5500XWJP4
share|improve this question
1  
Something that could be related: Samsung Galaxy 5 Wi-fi stops working: “ar6000 driver fails to load”. –  eldarerathis Feb 25 '12 at 18:10

1 Answer 1

I performed two steps to fix the issue:

  1. Settings -> Wireless & network settings -> Wi-Fi settings -> click menu button and select Advanced, Select Wi-Fi sleep policy - > Select Never.

  2. Dial *#*#526#*#* for WLAN Diagnostics. This will reload the Wi-Fi driver (I tried this before without step 1 and it rebooted my mobile).

share|improve this answer
    
Thanks for answer. I recently stopped to use wifi because my operator has cheap mobile Internet prices. I will check Your solution in future. –  Damian Melniczuk Jun 3 '13 at 13:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.