Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've got an ICS device, when I send SMS messages, G+ messages or GoogleTalk message my avatar appears beside each email.

When I send emails through my GMail account in a browser my profile picture appears next to them.

Inside the GMail app a profile picture appears for each of my contacts but not for me. The email address I send from is listed in my profile.

Can anyone tell me how to set this image?

share|improve this question

5 Answers 5

I just ran into this same issue. I think it's because I had a contact for myself in gmail that didn't match the capitalization that the gmail app (or maybe just android) uses for your personal email address (all lower case for me).

In any case, here's the steps I took that fixed it for me. I am running Jelly Bean, so it may be a little different for you.

  1. Open the gmail app
  2. Tap the gmail icon in the top left corner and take note of the capitalization of your email address on the top left
  3. open an email that you sent
  4. Tap on the place where your picture would be (it should be a picture of the first letter of your first name)
  5. Tap on your profile picture in the popup to go to the contact details
  6. Choose "Edit" from the setting dropdown in the top right corner (the 3 vertical dots)
  7. Change your email address to all lower case (or maybe whatever showed up in step 2. If one doesn't work, try the other.)
  8. Tap "Done" at the top left.

This fixed it inside my email. In order to also fix it in the email list, I had to also do the following.

  1. Go to gmail's "App Info" page. (under Phone Settings -> Apps -> "All" tab for me)
  2. Tap "Clear Data" once the numbers finish calculating (and ok on the warning popup)
  3. Open the gmail app and wait for your emails to re-sync
  4. Enjoy your face you handsome devil.

Hopefully this works for you or anyone else that stumbles across this thread.

share|improve this answer
    
I don't have such issue with the contact name capitalization, but the problem is there. Clearing GMail data does not help. –  AndreyT Dec 14 '13 at 1:55
    
It definitely worked for me, thanks. –  ChrisJ May 14 at 8:37

In gmail (on the web) you go to settings -> general. Under there is "My Picture".

Excerpt from Gmail Help:

  1. Click the gear icon at the top of any Gmail page.
  2. Click Mail settings.
  3. From the My picture section, click Select a picture. The Upload a picture window appears.
  4. Upload a new photo from your computer, or select a photo from Picasa Web Albums or your previous Google profile photos.
  5. Drag the selected region to crop your photo, or resize the region by clicking and dragging one of the region corners. Click Edit photo in Picnik to edit your photo.
  6. Click Set as profile photo.
  7. You can select whether you'd like all Gmail users to see your picture, or only those who you've allowed to chat with you, using the radio buttons next to your uploaded photo on your Settings page.

    • Visible to everyone means anyone who you email, or who emails you, can see your picture. If you have a public Google profile without a photo and you choose this option, your picture will be used on your Google profile and will be visible to others there.
    • Visible only to people I can chat with includes users who have been given permission to see when you're online and to chat with you.

As of the time that I am writing this, I believe that the Gmail picture and the Google+ picture are still separate from each other, but Google+ profile picture, IIRC, defaulted to this image.

I want to add that ICS added the "Me" Contact. From what I know, this contact is tied to your Google+ account, and no one has seem to find a way to edit the info without deleting the contact and re-adding it.

share|improve this answer
    
Hi Ryan, thanks for your response. I have added a picture there and it displays fine when I'm using gmail through the web browser. It just appears to be in the app it's not displaying. –  Liath Feb 28 '12 at 9:20
    
This answer, unfortunately, misses the point. The above steps are supposed to assign a picture to a user profile in GMail. But the picture is already successfully assigned and works fine in web version of GMail. It is only the GMail app that's broken. I tried reassigning the picture as described above, but it doesn't help. –  AndreyT Dec 14 '13 at 1:57

I tried the other suggested answers but nothing worked. I then simply sent an email to myself to see if my avatar would show up as the sender, it did, and all other emails in my inbox refreshed and it showed my avatar from then on.

share|improve this answer

I found an easy solution to the problem.

In Gmail App send an email to yourself. Open it. Tap on your avatar. It'll take you to your contacts. Tap on your avatar again. Select the 'upload image' option. Select the picture you wish to use. It'll take you to the edit image section. Once you finished cropping/adjusting your image tap on Save/done. Refresh your emails (or close and open the gmail app). And that's it.

At least it worked for me. Hope it works for others too.

share|improve this answer

Check your Picasa Web Album. I found that when I deleted my Profile Photo there, I was freed... finally! It took several minutes to update.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.