Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Vibrant support was dropped from CyanogenMod after 7.1 (Gingerbread) due to issues with failed 911 calls. I flashed 7.1 a bit before this was made known, and have since reverted to my stock-based ROM. This is obviously a bit concerning and I have a few remaining questions:

  • Did flashing CM damage anything? (I.e., will emergency calls work now that I'm on a different ROM?)
  • Can this happen with stock-based ROMs?
  • Was it all emergency calls, or just 911?
  • Is it related to Gingerbread?
  • Has it been fixed in CM? I've seen a few things both ways.
share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

The official announcement on the CM forums states:

  • The issue was in the RIL code, which is just typical code and libraries packaged in the ROM (e.g. /system/lib/libril.so, for example). The CM team recommended installing a Samsung ROM noting that any Samsung ROM is fine and any AOSP ROM would have issues. There's no permanent damage since the RIL code was replaced when you reflashed.
  • They specifically cited the issue was related to closed-source RIL code, so this wouldn't happen with a stock ROM unless Samsung severely borked their RIL code.
  • Only 911 was listed as a problem, but I don't know (and neither have the CM team ever stated) if other emergency numbers were affected.
  • Official support for the Vibrant didn't occur until 7.1, which was Gingerbread. It's really hard to say if older versions were affected, but I would assume yes (if they exist somewhere still).
  • The announcement states that the issue was fixed and the Vibrant is officially supported at this point.
share|improve this answer
    
Oh duh, I knew it wasn't supported before, and I know I've seen the original version of that announcement but couldn't find it again. Glad they fixed it ... very different from the previous "unresolvable" status. –  Matthew Read Feb 28 '12 at 3:59
    
@MatthewRead I can't believe you still have a vibrant and that you are still running TouchWiz. I didn't even revert when the e911 issue was identified. I am now just waiting for official cm9 support. The vibrant also now has a new maintainer for CM since this issue was resolved as I believe the original maintainer had the device, but did not have a working SIM for it as he is not in the US. –  Ryan Conrad Feb 28 '12 at 19:59
    
@RyanConrad I've been extremely happy with Bionix, and CM7.1 was really bad. Definitely going to try CM9 though now that I know I can. –  Matthew Read Feb 28 '12 at 20:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.