Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have an http proxy, which works OK, but there are some address on my lan which provides some web services.

I want to configure my device so that for some range of addresses the proxy is bypassed.

I have tried with 10.0.0.0/8, but it doesn't work!

share|improve this question
    
Could you add what device you're using? At this point I'm not confident it's related to ICS. –  Matthew Read Feb 28 '12 at 18:14
    
Acer Iconia A500. And yes, the firmware is not (yet) official. I'll update this question when the official ICS firmware is released. –  michelemarcon Mar 1 '12 at 8:53
add comment

2 Answers

Unless the firmware vendor has modified the function which checks the proxy bypass list, specifying IP address ranges in the list is not possible — all entries are compared like domain names. Also the * wildcard is not supported, but is implied at the start of the domain name, as answered here (still valid even for JB).

So, if you want to use the builtin proxy support, you either need to list all required IP addresses explicitly, or, if your LAN has a DNS server, and all local servers are under some domain (server.lan.example.com or server.local), add that domain (lan.example.com or local for my examples) into the proxy bypass list, then access local servers using DNS names instead of raw IP addresses.

Alternatively, if you have a rooted phone, you can install a third-party proxy app such as ProxyDroid or Autoproxy; they should be more configurable than the builtin proxy support code.

share|improve this answer
add comment

I don't think it understands ranges in that notation, have you tried 10.* or 10.*.*.*?

share|improve this answer
    
Yes, I tried. It doesn't understand 10.* or 10.*.*.* (the "save" button is disabled) –  michelemarcon Feb 28 '12 at 10:55
    
It seems to accept 10.0-254, can't test it now since my current connection doesn't use a proxy. If you test it, let me know and I'll update my answer accordingly. Oh, and try 10.0-254.0-254.0-254 style too. –  onik Feb 28 '12 at 11:05
    
It accept these settings, but still it doesn't work! At this point I believe it's a firmware bug. –  michelemarcon Feb 28 '12 at 14:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.