Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I recently switched from Linux to Windows 8 consumer preview. I have installed the latest android SDK including the Google USB driver. I connect my Nexus S to the laptop, the phone goes into USB debugging mode. But Eclipse doesn't detect it. if I do >adb devices, the phone doesn't show up. Please help!

share|improve this question
2  
I don't know that this will be feasibly answerable. Windows 8 is, as the name says, a preview version. It could simply be that Eclipse won't work, or that the adb driver is broken (I have no idea if drivers of that nature would be affected by changes from Win7->Win8). –  eldarerathis Mar 2 '12 at 14:45
    
what do you mean it goes in to "usb debgging mode"? This is a setting that you have to turn on in settings->applications->developemnt. ADB will not see the device until this is set to true. –  Ryan Conrad Mar 2 '12 at 14:47
    
Eclipse works fine on windows 8. The devices gets detected in the files transfer mode. Also, the emulator works fine. –  Ayush Mar 2 '12 at 14:48
    
@RyanConrad I have enabled the setting on my phone. As soon as I connect my phone to my laptop, the phone automatically enters into USB debugging mode, just like it did under Linux. –  Ayush Mar 2 '12 at 14:50
    
What your suggestions be if I facing the exact same problem under windows 7? –  Ayush Mar 2 '12 at 14:50
show 4 more comments

3 Answers

Try a powered USB hub. My (Win7) work laptop refuses to connect to my Samsung S2 except through the powered USB hub in the monitor.

share|improve this answer
add comment

Try to edit adb_usb.ini and add your device id you can find it by going to the device manager find the "Android ADB Interface" double click on it go to the details tab, and on the "Property" drop down menu select "Hardware Ids" on the box below it labeled "Values" You should see something like "USB\VID_2207&PID_0010&MI_01" The numbers maybe different based on your device vendor id, for example my vendor id is "2207" No open the adb_usb.ini located on the folders below and add your device id in hex format

for example my device id is "2207" I'll put it there as "0x2207"

It is usually located in

  1. XP: \Documents and Settings\.android\
  2. Windows 7: \Users\.android\
  3. Windows 8: I really dont know.

But if the folder doesnt exist try to create it by using cmd. And if the file adb_usb.ini also doesnt exist you can create it using notepad and only pasting only your device id and save it on the .android folder.

share|improve this answer
add comment

Try this: find the .android folder in your home directory, and replace the adb_usb.ini file with this one. this tells your computer to let adb work with a load of different usb devices. You may need to restart ADB via the command line:

adb kill-server
adb start-server

and now adb should show you your device

adb devices
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.