Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Motorola Xoom MZ601 but which is a GSM Wifi model. 3G on Xoom is not wokring currently. So I tried to debug the problem and when I did Fastboot getVars I got following info

NFOversion-bootloader: 1049
INFOproduct: xoom-cdma
INFOsecure: yes
INFOmodel: MZ600
INFOmemory-info: 0x101:0x5454:0
INFOmid: 001
INFOversion: 0.4
INFOversion-baseband: N_01.100.05P
INFOversion-baseband-2:
INFObattery-status: 64%:7.749V:0.9844A:36.75C
INFOunlocked: yes
INFOiswarrantyvoid: yes
all: Done
finished. total time: 0.946s

Can somebody help me find where does this info come from, as that partition or file may be corrupted.

The device is rooted.

share|improve this question
    
If your problem is that 3G isn't working and the Xoom seems to think it's a CDMA version instead of GSM, why don't you ask directly how to fix that, instead of this very obscure question that may not help you? You'll also want to include what you were doing before this happened. –  Matthew Read Mar 5 '12 at 18:44
    
Sorry if the question was unclear and I am absolutely trying to fix the 3g not working. But I have done my research before posting this question and fix I found for 3g not working didn't help. I have narrowed down the options to few issues and possible solutions. one of them was to replace the misc partition from working MZ601 as it contains information about baseband. But it didn't fix the problem so next possibility is to find this fastboot info as it is incorrect. Purpose of asking this question is to get specific anwsers and not suggestion of the solution that I have already tried. –  Kamil Dhuleshia Mar 6 '12 at 12:01
    
Also regarding what I was doing befor this happned - I have bought this xoom as second hand device and it is not working since I bought. I have then flashed sbf images and stock xoom images which failed in fixing this problem and also failed in updating the fastboot info too. –  Kamil Dhuleshia Mar 6 '12 at 12:03
    
OK. So you flashed a GSM image and verified the flash succeeded, but it still thinks it's CDMA? I assume you've verified it is GSM (based on the presence of a SIM card or something) rather than trusting whoever sold it to you. –  Matthew Read Mar 6 '12 at 16:53
    
Yes I have flashed the correct xoom image and it still thinks that it is CDMA not GSM. Also in Australia you can only get GSM Xoom and it came with the box that says MZ601. –  Kamil Dhuleshia Mar 7 '12 at 8:51
show 1 more comment

1 Answer

the information comes from the misc partition.. /dev/block/platform/sdhci-tegra.3/by-name/misc

if you dd if=.... of=/sdcard/misc.img then do an adb pull /sdcard/misc.img you will see.. I stuffed up a root and had CDMA crap in there from one of the updates.. now no 3g either :)

but that's where it queries the information from.. doens't do an mdm_ctrl commands to extract it or anything.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.