Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I just picked up an Android tablet running 3.1 and am having a nightmare of a time configuring the email settings properly. It's quite embarrassing, really. This is my issue:

I have several POP3 email accounts from domains that I host. I am able to configure the android tablet to receive email from those accounts quite easily. However, I cannot get the bloody thing to connect to the SMTP server. I am in Canada, so port 25 is blocked and I need to use either 26 or 587. I use 26 on both my Linux laptop and my Blackberry. The server does not require authorization so I have that disable on both of the other devices. However, when I try to connect using the Android tablet I keep getting a server error for an invalid username / password. I have unchecked the "Require Sign In" box, so the device should not be trying to authenticate, and I have verified that the service is not asking for authentication. Yet, here I am with an authentication issue.

I know this has to be something ridiculously simple, but for the life of me I can't find it. I'm using the same settings that work on other devices and getting zero love from this tablet. I've tried using 587 and get the same response. I've been all through the settings on the device looking for another place to turn off SMTP authentication but I can't find anything anywhere other than the mail program itself. What am I missing here?

share|improve this question
    
After you've set up the server and port, if you revisit the settings, do they still show what you've entered? This is a known issue in 4.x: code.google.com/p/android/issues/detail?id=36776 –  SQB Mar 1 at 7:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.