Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

On my Samsung Galaxy S, gmail only loads new emails when I press the 'refresh' button.

Is this normal ? Or should I set some options somewhere ?

I thought gmail should push emails to the phone.

share|improve this question
add comment

3 Answers 3

From the Home screen, go to Settings | Accounts & sync | <your account> and make sure that "Sync Gmail" is checked.

share|improve this answer
    
@ Al E.: This was already checked. And it seems to work. Seems I say because it can take a long time for a mail to arrive. Is there any way we can adjust the time period Gmail uses to push the mails in our direction ? And another thing: does the phone needs to be displaying it's screen ? I have the impression that mails never arrive when my phone is black (is running but not displaying anything). –  Edelcom Oct 9 '10 at 6:41
    
@Edelcom: I don't know what to tell you. Gmail to my Moto Droid works great, whether the screen is on or not. –  Al E. Oct 9 '10 at 20:44
    
@Al E.: So it does now here at home (connected to local wifi). Strange. It did not do that yesterday when I was working at my office (also connected to local wifi). Will have to investigate that a bit further. Thanks for your answer, though. –  Edelcom Oct 10 '10 at 5:44
add comment
up vote 4 down vote accepted

In answer to my own question (and in thanks for the answer already provided), but the problem was that in my office, my phone uses Wifi router which is connected to the internet via a firewall . And on this firewall one of the necessary imap ports was blocked.

My collegue changed this setting , and now gmail is behaving as expected.

I am really not in the habit of choosing my own answers as the selected answer, but for this question, this was the solution.

Hope it helps others !

share|improve this answer
    
Nice detective work! ;) –  gary Oct 13 '10 at 12:16
    
There is nothing wrong with selecting your own answer if it's what solved the problem for you. –  Al E. Nov 29 '10 at 15:31
    
Of course, if you had mentioned that this was only occurring at work while you were using the Corporate wifi, you might have gotten different answers. –  Al E. Nov 29 '10 at 15:33
    
@Al Everett: I agree, I should have edited my question. I did mention in in my reply to your answer, though. Problem is, you have a new device, you play around with it. Use it here , use it there and notice something not working. The first thought is that you are doing something wrong. Second thought is , asking it to the nice people at Android.Stackexchange. Than you use the device or program some more and slowly start to see a pattern emerging. In the end a solution is found, either by reading answers, of by yourself. So I answered my own question in the hope that it will help someone else. –  Edelcom Nov 29 '10 at 15:43
add comment

In addition to what Al E. says, you also need to make sure Syncing is general is on. Form the Home screen go to Settings | Accounts and sync and make sure both Background data and Auto-sync are checked.

share|improve this answer
    
+1 for providing more steps that are vital. Also, inside the account entry, you need to check "Sync Gmail" (to get the mail data-type). It also shows the last sync time-date as well. –  benc Aug 3 '11 at 15:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.