Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Over the past week, whenever I try to open the Play Store/Market app on my phone, the app thinks for a while and then displays this error message:

Authentication is required. You need to sign into your Google Account.

But I am indeed signed into my Google account, as seen in other Google applications running on the phone, and as seen if I open the menu in the Market app and click the "Accounts" button.

I suspect this might be related to the fact that over the past few months I've had two different Google accounts synced to this device, and I have recently removed one of them from the phone. No other Google application has had any problems with removing one account.

Does anyone know how I can solve this issue? I can still install applications by using the market website (now "Google Play"), but this is still a big inconvenience. I also think I stopped getting updates.

share|improve this question
    
Are you signed in to talked? –  roxan Mar 7 '12 at 10:19
    
@roxan I don't know what "talked" is. I'm signed-in in Google Talk, if that's what you mean, as well as other Google apps such as Gmail and Docs. –  Oak Mar 7 '12 at 10:44
    
Yes, sorry I meant that :) –  roxan Mar 7 '12 at 13:31
    
I'd try clearing the data for the Market, Talk, Google Framework, and anything else that seems potentially related. If that doesn't work I'd say this is one of those ridiculous Market issues no one knows how to fix without a factory reset. –  Matthew Read Mar 7 '12 at 18:15
2  
Go to Settings -> Applications -> Manage applications -> All and you'll see a "Clear data" button when you click on an app. It removes all the data used by the application (settings, etc.) except what it stores on the SD card, if anything. –  Matthew Read Mar 7 '12 at 19:20

5 Answers 5

up vote 3 down vote accepted

I went to Settings -> Applications -> Manage applications -> All, chose the Market application in the list, and clicked on "Uninstall updates" button which appeared there. It gave me an old, but working, version of the market app. I hope it will update itself in the future and will continue to work properly.

Thanks to Matthew for inspiring me to look over there.

share|improve this answer
2  
It doesn't work! –  Hamed Rajabi Apr 19 '12 at 8:46
    
I had to roll back updates, restart phone then re-update and it let me access the app that had the issue. –  Martin Lyne Dec 2 '13 at 9:47

This worked for me: System settings > Apps > "All" (tab at top) > Google Play Store

Then press buttons in order: "Force stop" and "Clear data"

Exit Settings. Start the Play Store. Press at the top left top open the menu options.. Verify you have the correct account selected.

share|improve this answer

I figured it out!!! Finally!

You have to remove all your accounts from your device and re-add them. Or, just re-sync your google accounts from the Accounts & sync menu.

Go the Settings > Accounts & sync > Click on your account then remove account.

I removed all of my accounts that I had at that time, hopefully you haven't forgotten your passwords for your account. After I had done this, I restarted the device.

When my device came back on, I clicked on my Google Play Store, from there I was asked to sign in my account. Boom! That easy!

share|improve this answer
    
You just need to remove your offending account. Click on it and then you have a menu option to remove it. –  Adi Nov 12 '13 at 21:42

This happened to me when I changed my Google account password. A simple phone restart did the trick for me. (Android 4.2)

share|improve this answer

I guess this happens when you change your Google account password, please see below steps that was helpful for me.

Tap (touch) on Play store icon → touch menu key (key on the left side of home key on bottom) of the phone-select Settings-then select "Content filtering"under user controls then tick your selection or select all and click- OK. Then it might ask your new password, enter your Google password, then you can open Apps (Play Store).

share|improve this answer

protected by Community Aug 31 '12 at 14:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.