Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I would like to add Namecoin support to my Android phone (galaxy s) like this: http://dot-bit.org/How_To_Install_Dns_Suffix

I managed to mount the system as read-write and add a resolv.conf to my etc folder like this:

search namecoin-suffix
nameserver 8.8.8.8

Now it works fine with nslookup but not with ping or any other program. Is there anything else I have to do?

edit 2012-03-11:

looks like Android does not use resolv.conf at all.

tried these properties but no luck yet (can be read/set with getprop and setprop from the shell):

net.dns1
net.dns2
net.dns.search -> space separated domain search suffixes (used e.g. by VPN)

There are additional dns server properties that may have to be changed. The properties are not persistent over a reboot.

share|improve this question
add comment

1 Answer 1

I haven't tried this, but a quick look at Android's bionic libc sources seems to indicate that Android might use /etc/ppp/resolv.conf:

(from http://code.metager.de/source/xref/android/4.1.1/bionic/libc/private/resolv_private.h#113)

 92 /*
 93  * Resolver configuration file.
 94  * Normally not present, but may contain the address of the
 95  * initial name server(s) to query and the domain search list.
 96  */
 97
 98 #ifndef _PATH_RESCONF
 99 #ifdef ANDROID_CHANGES
100 #define _PATH_RESCONF        "/etc/ppp/resolv.conf"
101 #else
102 #define _PATH_RESCONF        "/etc/resolv.conf"
103 #endif
104 #endif
share|improve this answer
    
Good call but still does not work with /etc/ppp/resolv.conf –  phelix May 27 '13 at 15:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.