Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Once I've checked off the box to "allow automatic updating" for an app in the market, is there any way to undo this without uninstalling and reinstalling the app?

Moto Droid running 2.2

UPDATE: Apparently I am losing it. Originally it happened with PDAnet. I accidentally clicked the checkbox and as soon as I did the option disappeared. I tried restarting the market, restarting the phone but the option never reappeared. I uninstalled it and reinstalled it and I had the box back, unchecked. I was afraid to test it out on other apps until the answers below confirmed that either it was an isolated bug or I was crazy. Needless to say I have the option to uncheck it now.

share|improve this question
add comment

4 Answers

up vote 4 down vote accepted

On the HTC Incredible I just searched for the particular app in the market, selected it and unchecked "allow automatic updating" from there. Hopefully it works that way on your phone (and others).

share|improve this answer
    
That is odd. I don't have that option. Once I click it, the option goes away and apparently doesn't com bacl. –  Matt Oct 9 '10 at 18:38
    
That's extremely strange - gary's answer is right for me on my Nexus One. The checkbox is always there for me. Which app are you talking about? –  Konklone Oct 9 '10 at 18:39
    
I noticed the app eventually disappears from my download list after I set it to auto, that's why I had to search for it in the market. It's surprising that would differ between phones. –  gary Oct 9 '10 at 18:51
    
It's not doing it any more. After I uninstalled an reinstalled the app, it works as you described. –  Matt Oct 9 '10 at 23:41
    
I had to kill the app before the checkbox appeared. Perhaps you can't change this setting in a running app for some reason? –  user3090 Feb 23 '11 at 14:41
show 2 more comments

I just went to Market | Downloads and selected the app. The "Allow automatic updates" checkbox is at the top of the page and checked, allowing me to uncheck it.

I also have a Motorola Droid running 2.2.

Is there a particular app with this behavior? Maybe it's a system app that requires automatic updating.

share|improve this answer
    
It was PDAnet, but now it appears to be working fine just like you guys said. –  Matt Oct 9 '10 at 23:37
add comment

I had the same problem and found this post. The check box finally came back after I force closed the market and reopened it. I think this is the primary reason it will not let you change the "automatic update" option. Hope this helps :)

epsilon

share|improve this answer
    
You know, I have now seen this too. I have to believe that this is a bug in the Market. –  Al E. Aug 26 '11 at 12:20
add comment

I just had this happen to me (HTC Incredible, Android 2.2). An app updated automatically, I decided to turn auto updates off, and the checkbox was gone. Happened with two happens, My Tracks and Maps, both from Google. I found that if I pulled down the notifications panel and tapped on the "Successfully Updated" message for the app to make it go away, then returned to the Market page for the app, the checkbox had reappeared and I could disable automatic updates. Tapping the notification also starts the app, so it could be either removing the notification or opening the app once after the update that made the checkbox reappear.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.