Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have WhatsApp installed on my HTC Sensation running Android 2.3.4 (Gingerbread). I also have other social contact related apps such as Google Voice, Facebook, LinkedIn, Twitter, etc. For my Google Contacts, it links each of these services up to the people in my address book.

When using WhatsApp, only a few of my contact's icons shows up for the screen with recent messages. When I view the contact in my address book, they have an icon (headshot) either from Google contacts, Facebook, or some other social service.

Why do only some of my WhatsApp contacts have icons showing? The other WhatsApp contacts default to an Android avatar. I've refreshed the WhatsApp contacts list and the problem still persists.

share|improve this question
1  
Same stuff started to happen to me recently. Suddenly all display icons were gone. And not just in Whatsapp. Also in Viber. –  Dbugger Jun 1 '12 at 21:36
1  
I might be wrong, but isn't the profile pictures in Whatsapp contacts put up by the users themselves? Which means to say, if your contact did not put up a profile photo in his/her Whatsapp profile, it would default to the Android avatar. Certainly seems that way to me... –  Void Aug 30 '12 at 3:27
1  
@Void WhatsApp contacts can sync with existing Google Contacts. So even if they don't set one, it can use the sync'd icon, if it exists. –  spong Aug 30 '12 at 5:03
    
well, my whatsapp is with same issue... –  kokbira Nov 6 '12 at 18:10

4 Answers 4

Maybe you are talking about the contact picture. The contact picture is only visible if the user has specified it.

By default you can have contacts sync with all account but Profile pictures will not be sync'd in app. Each app may have different profile pictures.

Try this: go to sdcard -> whatsapp -> profiles Pictures->

Here you should see what and how many pictures are there. Only those will be shown in WhatsApp contact list.

share|improve this answer

Try to do as WhatsApp FAQ say, mainly (try other way on link too):

you can use all your contacts, not just the "visible" ones. To do this:

Go to the Contacts Help screen: From the main Chats screen, tap the pencil icon > [Menu Button] > Help Scroll down and tap the "Show Invisible Contacts" button If you have any invisible contacts, a checkbox will appear. Make sure that it is checked.

The "Contacts Help screen" is accessible by WhatsApp menu.

Doing so, my contacts that were invisible - that ones that use it and change its visualization are probably most of people that use avatars - become visible again.

share|improve this answer

Simply, Your phone is not giving ample space to Whatsapp. If that contact is stored on your sim card, move it to phone. In 2.2 to 2.3.6, we are a li'll helpless as it will not update automatically.

a li'll tech :

the contacts photos which are not being shown are those whose photo tag is not saved in your device.

Now just make sure that all tags are there in your phones contact list. Android automatically sets ph_tag=FALSE if no contact photo is there and anything (any app) below Android 3.0 (API level 11) can not change the tag to TRUE.

So when whatsapp gets ph_tag=FALSE against any contact, no space is allocated to it for saving a profile pic.

There may also be such issue that the Raw Contact is on SIM space and not in phone memory, hence it is not getting any space to save DP against that particular contact.

share|improve this answer
    
Nice idea -- but how to make sure? Can you please answer that from a "simple end user's perspective" -- one that doesn't now about API levels and where to find/adjust some ph_tag? –  Izzy Apr 23 '13 at 21:29
    
Simply, Your phone is not giving ample space to Whatsapp. If that contact is stored on your sim card, move it to phone. In 2.2 to 2.3.6, we are a li'll helpless as it will not update automatically. –  Manan Merevik Sharma Apr 23 '13 at 22:54

Is the app up-to-date? If not, just go to the Play Store and update it.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Ryan Conrad Jan 28 '13 at 13:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.