Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Samsung Galaxy Nexus running Android 4.0.2. I have a corporate email set up to Microsoft Exchange. My sys admin said we use the default mobile policies for Exchange, but he doesn't know the details.

My phone's Screen Lock setting is set to None and I cannot change it. If I select PIN, it asks me to enter and confirm a PIN, then returns to the Security settings page and shows my Screen lock is set to "None"

After reading I thought it best to at least have a PIN, but right now I can't set one. Any suggestions?

--- update

I just did a test (with my sysadmin's help). We set up a Nexus One with Android 2.3 and the lock screen settings worked fine. Is there something in ICS?

share|improve this question
Get the sysadmin to find out the details. Let him know that it's his problem if your unsecured phone gets stolen with company data on it and it's because he didn't configure the Exchange policies properly. – Matthew Read Mar 14 '12 at 20:27
I'll update the question with some new info – Michael Levy Mar 14 '12 at 20:49

Well. First, I deleted my Exchange account. Then I was able to change the screen lock settings and the change would be displayed in the settings page, but when I locked the screen, no PIN or pattern was required to unlock. Then I power cycled the phone. After that I was able to successfully use Screen lock settings. Then I added back my Exchange account, and the phone continued to work fine.

I have no idea what the root cause of my problem was, but it is all working now.

share|improve this answer

If you have a VPN set up on your mobile phone, the OS will not allow you to remove the PIN... I installed VPN and it asked me to secure the phone and led me to the PIN settings and I set a PIN... Later, when I wanted to remove the PIN, it won't allow me and it didn't come to my mind that it was because of setting up the VPN.

I had to completely get rid of all the VPN settings to be able to remove the PIN.

However, in your case, the problem is opposite but I posted this for information and this may help.

share|improve this answer

I read you post with interest as I am having trouble since updating my phone to ICS and getting it to work with Exchange 2003. Since updating to ICS I can not change my sync settings from hourly of peak and every 15 mins in peak hours if I change the setting the next time a sync happens it get changed back.

The same phone worked just fine when it was on GB so I am thinking there are a few bugs in ICS

What I have noted is if I put on security policy on out Exchange server (meaning I have to put a pin in on the phone) it all seems to work fine. Odd I know I am guessing that it will take a long time for google to fix this if they bother at all.

share|improve this answer
If this is a recurrent issue, perhaps reporting it to Google would be the appropriate solution to let them know and schedule a fix. – Zuul Nov 3 '12 at 1:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.