Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have got a replacement phone for my HTC Desire while the latter is in repairs. It's Sony Ericsson XPeria X10 Mini. Since it's also an Android-based device I hoped I could sync my contacts and calendar events. However, as it seems it only syncs one of my calendar in full (namely Ukrainian Holidays, which is not as important) and new events for other calendars. I wasn't able to find option for selecting which calendars to sync as in HTC Desire. How can I sync my old events (including ones that are recurring in future)? It would be sufficient to just have my primary calendar on the phone.

P.S. I tried cleaning Calendar Storage data and synching manually again (from Settings -> Data Synchronization -> Auto Sync and then select Calendar). It took substantial time (~5 minutes), so I hoped it have synched old events, but they are still not in my calendar. It has even removed events that I have added today. New events get synched as previously.

share|improve this question
1  
The settings for the Calendar app should have a place for you to indicate which calendars to sync. –  Al E. Apr 18 '12 at 13:27
add comment

2 Answers

up vote 0 down vote accepted

This sounds like the X10's calendar app (and possibly its settings). A quick 'Google resulted in this quote from a Groups discussion that relates to your problem:

I have found that in at least one scenario, the X10 mini calendar app itself is to blame. When I installed the app "business calendar free" on my X10 mini pro, I could see everything and sync flawlessly, while the built-in calendar still showed nothing.

Have you tried a 3rd-party calendar app like the aforementioned Business Calendar? If a 3rd-party app works you'll at least know where to start digging. It also happens to be an app I use and recommend as a replacement for stock calendar apps, problems or not.

share|improve this answer
add comment
  1. Go to Settings -> Accounts $ sync -> Add account
  2. Add your existing Google account here
  3. Check the Sync Calender checkbox to synchronise your calender with your Google calender.
share|improve this answer
    
There is no Accounts and synchronization in Settings. But I have added Google account and enabled Calendar sync when setting up the phone. Also I wouldn't get new events if it was disabled. –  Sergiy Byelozyorov Mar 19 '12 at 11:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.