Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Recently I bought a Spice MI 280 with Android 2.3.4, I downloaded apps from the Android Market like App2sd, Task killer, Soundhound etc.

A few days ago Android Market was upgraded to Google Play and when I try to open it it shows a no connection: retry error...although I can browse the net through Opera and uc browser without any difficulty.

When I open YouTube through Opera it shows the main page of the site, but then when I try to play a video it shows cannot play the video.

I have tried adjusting the current date, clearing data and caches etc. I've tried a factory data reset but its asking please input phone password. Any suggestions?

share|improve this question

3 Answers 3

Okay, I ran into the same issue and finally found a fix that worked!

First off, go to settings>Applications>Manage Applications>Google Play Store and select "Clear Data" Then, return to your home screen and just wait for the Play Store to auto-update. If it does not come up on its own, re-open the store and select "update" Finally, close the app (after it boots up), give your phone another minute,and have at it!

After trying this, my Play Store has been working just fine. I hope that helps!

Cheers

share|improve this answer
    
The same kind of technique applies to some, not all, apps. :) Go as far as Settings > Applications > Manage Applications, select the app that's giving grief, then Clear Data –  t0mm13b Jun 30 '12 at 0:07

I'm finding that I can install apps again if I downgrade from Google Play Store to Google Market on an HTC MyTouch running Android 2.2.1.

To downgrade, go to Settings -> Applications -> Manage applications -> Downloaded -> Google Play Store -> Uninstall updates.

share|improve this answer

I had the same problem with my Xperia ZL. It was supposed to be because of incorrect setting up when the phone booted for the very first time.

I did a factory reset and the issue is fixed for me. So simple.

Good luck.

share|improve this answer
    
If you have root access, you can also clean up the "host" file content.that sould also work. It is under /etc/ directory. –  Engin OZTURK Jul 4 at 7:19

protected by Community Jun 30 '12 at 0:15

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.