Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay, got a bit carried away in Root Explorer and deleted GTalk. Cant access Google Play. I tried reinstalling versions online, those crashed instantly. Then, i grabbed my ROM zip and pulled out Talk.apk and put it into system/App and installed it. Google Talk doesnt crashes anymore, but play still does. Any ideas? I am using a Virgin Mobile WFS.

Sorry for the lack of ' characters, my autocorrect on my phone is being weird.

share|improve this question
Have you tried clearing Google Play cache and data? – Lie Ryan Apr 7 '12 at 8:05

I was just browsing around for this issue and found this,

    I had exacly the same trouble with Google Play and I have managed to revert it 
    back to original working version of Android Market. In Options (Android system   
    settings) go for Applications. Choose Google Play. Clean cached data. Remove this 
    application. After these steps Google Play dissappeared from my droid and I could   
    put back Android Market icon onto my desktop and I can use it for installing new 

Link to source : Link to forum

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.