Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My i7500 doesn't unlock anymore (the screen unlock). I have a feeling the actual, physical button is broken, because the phone is on and responds to the power button being held down, but won't unlock.

Things I tried that failed:

  • Rebooting does nothing.
  • I tried the sqlite thing (updating one of the settings so that the phone doesn't lock by default or whatever), but my phone is not rooted, so I only got "access denied."
  • I tried using adb shell to send the command input keystate 82, which supposedly unlocks the phone, but nothing happened.
  • Sending event send EV_KEY:KEY_SOFT1:1 via adb (I get access denied).

If I can figure out how to unlock it once, I think I'm game. The phone runs a non-local version of Android 1.6. It's not rooted, sadly, and I really want to avoid formatting it if possible.

Here's what I'm doing right now:

  • Install NoLock via adb: adb install E:\download\NoLock1.05.apk
  • Run NoLock via adb: adb shell am start -n org.jraf.android.nolock/org.jraf.android.nolock.activity.MainActivity (prints Starting: Intent {cmp=org.jraf.android.nolock/.activity/MainActivity })

So, if I can only unlock my phone now, and configure NoLock, I think I'm good.

How can I get my phone to unlock, and how can I then unlock it without the unlock key? Is the current path of nolock going to work?

Why doesn't sending input keystate 82 unlock the screen?

Why doesn't NoLock automatically unlock the screen?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

This happened to me again. The process of unlocking was as follows: - Call the Android phone from a normal phone - Pick up the phone - Press the options button - Click the button to add someone to the call - Press the "go back" button

It should return you to the home page.

After that, setup Pattern Unlock. It only uses the touch-screen, so it works with a broken lock button.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.