Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My Galaxy S2 has suddenly started reading all homepages out loud, and it is really annoying. Does anyone know how to stop it?

I am running the new ICS software.

Update

When the computer voice is reading out loud, it seems that I can turn down the volume of that voice, which mitigates the problem for now.

Also, it seems that it is only the browser and the facebook apps for which everything is read out loud.

Update again

In Settings -> Applications -> Running I see a "Voice commands", and under that the Samsung TTS process is running. When I force close that one, a voice says "driving mode off". However, the process is relaunched immediately again.

Seems the suggestion about disabling driving mode is the way to go, however I cannot find any such option anywhere in the settings menu.

Update again again

This is getting pretty weird. I managed to disable driving mode. You can do that by going to the voice command app by double tapping the "home" button. However, that did not help, it is still reading all homepages out loud.

Any help please, it would be very much appreciated?

share|improve this question
1  
Can you once look at Menu -> Settings -> Accessibility –  roxan Apr 8 '12 at 6:48
    
I have looked in most of the settings menu, including that one. And there is nothing that indicates that it should be reading anything out loud. –  bjarkef Apr 8 '12 at 10:53
    
@bjarkef The TalkBack service is off? –  onik Apr 12 '12 at 12:54
    
@onik: I cannot find anything called TalkBack in the settings menu, nor any such running process. Where should I go look for TalkBack? –  bjarkef Apr 12 '12 at 14:53
    
@bjarkef It should be among the first options under Settings -> Accessibility if it's available. If not, then disregard. –  onik Apr 12 '12 at 17:30
show 1 more comment

3 Answers 3

Check your settings for Settings -> Accessibility -> Install web scripts and make sure that it's turned off.

For JellyBean Settings > Accessibility > Vision > "Enhance web accessibility" -Set to "Do not allow" This fixed my issue, guess I should stop playing with 500 settings at one time. Also try Settings>accessibility>Hearing>Turn off all sounds checkbox

share|improve this answer
add comment

Had the same problem with text to speech on my Galaxy Tab GT-P7500. I resolved the problem by disabling Accesability under Settings on my device. The Accesabilty fuction hinders/allows application to interact with you device. So when I would like to read text and would like to listen to it read out aloud then enables Accesability. Hope this have helped.

share|improve this answer
add comment

Turn off Car mode / Driving mode, maybe. Perhaps in ICS - it is under Android's SETTINGS > VOICE INPUT AND OUTPUT

share|improve this answer
    
I cannot find anything called "car mode" or "driving mode" in any of the settings menus. :/ –  bjarkef Apr 12 '12 at 10:51
    
Finally found that setting, see my updated question, it is turned off, it does not mitigate the problem. :/ –  bjarkef May 7 '12 at 14:02
    
I have an S2 but running Gingerbread. When Driving mode is on - incoming calls and messages are read out. There isn't any option to read the text in the browser. Is it only the default web browser that reads out the content of the page or do you have Text to Speech in other apps reading out what's on-screen as well? –  Sparx May 8 '12 at 8:02
    
Since you have ICS, open the keyboard and check the keyboard settings - i think the default ICS keyboard has a text to speech feature included also. –  Sparx May 8 '12 at 8:09
add comment

protected by Community Jul 9 '12 at 23:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.