Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm in the UK. My Nexus S received its update to 4.0.4 yesterday, and I now have the following problem.

If I have a contact with (say) the number 07123456789 and I receive a text from this contact, it comes up as +447123456789. However the phone no longer seems to recognise that these numbers are the same (i.e. one is with the international extension, one without) and the contact name is not displayed with the text. Is there a setting or anything that will fix this?

share|improve this question
add comment

3 Answers

up vote 13 down vote accepted
+100

This is a known problem with ICS (up to 4.0.3, I think) :

If you follow this link you'll also see a solution to the problem (I'd recommend backing up your contacts first, just in case):

  1. Assuming your phone is synced with Google Contacts
  2. Disable contacts syncing. From the home screen: Press Menu -> System Settings -> Accounts & sync
  3. Erase all contacts from the phone: From the home screen: Press Menu -> Manage Apps. Scroll down to Contacts Storage and press Clear Data.
  4. Restart the contacts sync as in Step 2.

I also have a Nexus S and am in the UK and have just had version 4.0.4 rolled out to me yesterday, I haven't had a chance to download it yet BUT 4.0.4 should have 'Improved phone number recognition' according to the Android team, I'm assuming that's a reference to the problem we've been having and should fix it. Here's the link to statement from the team:

Here's another solution, that's been posted on the top link I gave you, I haven't tested it personally but others in the thread seem to have and have said it works. Try the first shorter one before this though. Here it is:

    1- menu --> people
    2- option --> import/export
    3- export to storage --> OK
    4- option --> import/export
    5- import from storage --> after searching
    6- import one vCard file --> ok
    7- choose the file which you exported early (00001.vcf) --> wait for import
    8- now your issue is solved and you can try if it works with you. but we got another error of duplicated names here.

    if you want to solve the duplication on names here. follow the below:
    1- menu --> settings
    2- accounts & sync
    3- enable the sync and choose to sync your gmail account
    4- after finishing the sync. go to your laptop and open your gmail email.
    5- press on the contacts tab on the left side 
    6- select all the contacts --> more --> find & merge duplicates
share|improve this answer
    
Thanks - the second solution seems to work for me. I will check if there are any more issues in the next day or two. Maybe remove the first solution, as the second is pretty simple? Also my phone was already updated to 4.04 but maybe it just needed this kick up the butt. –  Mr E Apr 11 '12 at 12:45
    
I'll move the second solution up to the top but keep the other one in at the bottom just in case the first doesn't seem to work for people. Let me know if there's any more issues with it and what they are, I'm going to try it when I get in as well as I've still got the same issue, just needed a bounty to get me to look at how to solve it. –  Peanut Apr 11 '12 at 12:52
    
Thanks for the edit as well! –  Peanut Apr 11 '12 at 12:53
    
Cool, it definitely seems to have worked, got a few people to do test replies (which come back as +447...) and no problems so far –  Mr E Apr 11 '12 at 13:04
add comment

OK, nothing works for me but I found something in the web that could help mitigate this problem. It consists of editing "/system/build.prop" and adding this: "ro.phone.min_match=8". Of course, you should replace the length "8" to a value more convenient to you. (in fact, 8 is the best number)

Then, you need to restart the phone. Some phones put the cell on hibernate when you power down. So try to restart instead.

share|improve this answer
add comment

It might help installing an Android app called Right Number (source available). It reformats the numbers of all your contacts to the international format, and then automatically adds the local prefixes whenever you do a call.

In other words, keep all your numbers in a common, sane format, and then stop worrying about those prefixes.

Disclaimer: I know personally one of the authors of that app.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.