Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It just displays Connecting... forever when I plug in the phone (through USB), and nothing else happens. What should I do?

I just installed Kies, v2.3.0.12035_16

share|improve this question

I had the same problem. I fixed it by reinstalling the latest version of Kies and deactivating USB-Debugging BEFORE I connected my phone (Samsung Galaxy XCover) the first time.

share|improve this answer

I have same problem, plus i have try some things:

debug mode (off) then plug debug mode (on) then plug plug then debug mode (first off then on and vice versa)

rebooted phone and pc

installed kies, and USB drivers over the past installation

rebooted phone and pc

unistalled kies, usb drivers rebooted phone and pc reinstalled kies, usb drivers rebooted phone and pc

deleted manually all the kies files, registry entry, usb drivers rebooted phone and pc installed kies, usb drivers rebooted phone and pc

I have try to install kies on several computer, but all are 32 bit (win xp or at least vista)

actually, my phone has been connected to kies only one time... i remember that time it was some of the first try, about a year and half ago... then, nothing.

share|improve this answer

Before ur usb connect with the computer, go.Setting-->Application-->development-->USB debugging(no tick) open Kies connect USB maybe it is work.... if still not , reopen the phone..connect again... i hope that it can help u.....also understand my poor eng....

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.