Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I get 4.0.4 OTA with my Nexus S today. After downloaded the update package, i click "Reboot to install", but unfortunately the phone did't reboot successfully, so i boot it by myself. I checked the android version in the settings, it's still 4.0.3, and the system update never noticed me to update to 4.0.4 again. Does this means i can't get the 4.0.4 later? How can i try to install it again?

My phone was rooted before, Any help will be very appreciated.

Anyone got the same problem as me? it frustrated me.

share|improve this question
Especially if you were already offered the OTA, consider a trick from the Nexus One days. Open up your dialer and dial the following number: *#*#checkin#*#*. This was suspected at some time to coax the system into checking for available OTA updates. As there is a good chance this won't work, I'll leave this a comment. – ctt Apr 10 '12 at 1:49
@ctt I tried and received checkin succeeded notification, and when i click it, it disappear. – dreamtale Apr 10 '12 at 1:58
If that doesn't work to jumpstart the OTA checks, it may just be a case of waiting it out. If you're impatient, though, there are those .zips that have been floating around; but use at your own risk. – ctt Apr 10 '12 at 1:58
@ctt All right, i will wait it out, also, i want to know anyone got the same problem as me, it frustrated me. Anyway, thanks for your comment. – dreamtale Apr 10 '12 at 2:05
up vote 1 down vote accepted

I unroot my Nexus S (If you don't know how to unroot Nexus S, you can see this), then received the OTA again and upgrade to 4.0.4 successfully.

When updating the android, the screen maybe dark for a while, just be patient and wait it
restart automatically.

share|improve this answer

Try going to `Settings -> About phone (at the bottom) -> System updates. If there's nothing there try the 'Check now' option and this should make the phone check for new updates.

share|improve this answer
Any reason for the downvote? – Peanut Apr 11 '12 at 17:18
I have tried this, but it didn't works. Anyway, Thanks for your answer, I found someone may faced the same problem, he unroot the phone and received the OTA again. I will try. – dreamtale Apr 12 '12 at 5:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.