Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Tech_7 from Chinavasion, S3C6410 Android 1.6;

When I plug it into the usb port, it shows up in the Device manager as HiDROID, but the driver is not installed.

How can I get the USB driver working?

share|improve this question

1 Answer 1

up vote 2 down vote accepted
  • Install the avd & sdk manager - I'm assuming you use c:\Android_SDK

  • Edit c:\Android_SDK\usb_driver\android_winusb.inf
    Find the section [Google.NTx86] and add the following:

;Techpad
%SingleAdbInterface% = USB_Install, USB\VID_18D1&PID_0002
%CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_0002&MI_01

Find the section [Google.NTamd64] and add the following:

;Techpad  
%SingleAdbInterface% = USB_Install, USB\VID_18D1&PID_0002  
%CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_0002&MI_01  
  • Edit .android\adb_usb.ini and add the following:

0x18D1

Note: This corresponds to the device id up top

  • Plug device in - you should have an unknown device in the device manager.

  • Update the driver on it and manual select the location of c:\Android_SDK\usb_driver.
    It should install the driver and show up as an ADB Device.

  • Run adb kill-server then adb devices

Remember to turn on USB debugging from the application settings as well

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.