Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy 10.1, running Android 3.2, which I've rooted.

When I plug it in by USB to my Ubuntu computer, it looks like this:

enter image description here

There's about 24 or so directories, all numbered as shown in the image. As far as I can tell, they don't correspond to any directories actually on the device, and I can neither find any files I think should be on the device or transfer any files to the device. (To be accurate: I can copy files to one of the weirdly numbered directories, but then I can't find them if I try to look for them from the tablet interface.)

What's going on, and, more importantly, how do I get a normal connection to my tablet so I can transfer files back and forth?

Update 1: I have learned this is probably "MTP mode". I can't seem to find any option to disable or change it.

Update 2: I have tried turning "USB debugging" both on and off, and neither way seems to make a difference.

Update 3: I've asked about this issue also on the Ubuntu SE site, in case part of my problem is on the Ubuntu side.

Update 4: Here's another error message I get if I try to use mtpfs to connect to the Android device:

enter image description here

share|improve this question

closed as too localized by Dave M G, Izzy, ce4, roxan, Zuul Dec 3 '12 at 13:36

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Voting to close as this has been rendered moot by upgrading the tablet to Android 4. –  Dave M G Dec 3 '12 at 7:01
1  
Put it as answer and mark the answer as accepted. –  Flow Dec 3 '12 at 8:12

2 Answers 2

It seems that you're connecting the tab in Media Player (MTP) mode. Try switching it to Camera mode, it usually gives better results. If I remember correctly, this option can be found in Settings -> Storage -> Menu button (top right) -> USB computer connection.

share|improve this answer
    
Thank you for responding. However, there is no menu button at all under storage. There's just a bar graph showing me the device's storage memory usage. And I might be blind to the obvious, but I can't find any "USB Connection mode" option anywhere in the settings interface. –  Dave M G Apr 12 '12 at 10:42
    
Hmm, I was almost sure it was there. Now I'm running ICS so I can't check. Then your best bet would be to try gMtp, here's some instructions: forum.xda-developers.com/… –  onik Apr 12 '12 at 10:50
    
Hey, can you find the menu Settings -> Wireless and networks -> USB Settings? This might solve your problem. –  onik Apr 12 '12 at 12:11
    
There's no Settings -> Wireless and networks -> USB Settings either, I'm afraid. The only USB setting that I have found anywhere in the settings is Applications->Development->USB debugging. As mentioned in the question, it has no impact on this issue. –  Dave M G Apr 12 '12 at 13:40
    
Also, I tried to install gmtp as you recommended in a comment above, and I got through the whole process, but when I actually attempt to connect to my device through the gmtp interface, it hangs. –  Dave M G Apr 12 '12 at 13:50

Most likely hidden directories used by Android to store hidden data, that are shown/visible when you connect it to your computer.

Try using root explorer on your tablet to see the directories.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.