Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

On Samsung Galaxy S2 (not rooted) everytime I accidently double press the home button, the voice command app comes up.

How can I disable this?

share|improve this question
add comment

10 Answers 10

For a non-rooted phone, this is the best I have found:

  • Double-tap, select Menu, Settings
  • Voice Talk Seetings -> Speak Prompts: uncheck

Now if you double-tap, a short sound will be heard, but you won't here the "What would you like to do?".

share|improve this answer
    
So double tab started the voice input, right? I need to ask, because I have Cyanogen Mod now. If this setting is inside the voice input app, I had to accept some terms of use from Samsung, but I didn't want to. –  Martin Aug 4 '12 at 10:32
    
Yes, that's right. That setting is inside Voice Input so you need to open it in order to change that setting as far as I know. –  Carl Aug 4 '12 at 13:59
3  
So I have to accept terms of use for the software I don't want to use to disable it. Good job, Samsung ... –  Martin Aug 4 '12 at 15:45
add comment

I have disabled it using App-Freeze on Titanium Backup. This works well, and is entirely reversible, but appears to require both the Pro key (paid) and root.

A possible alternative would be removing it using either the terminal or ADB. The apk in question is /system/app/VoiceToGo.apk (com.vlingo.client.samsung), and my phone hasn't had a problem with it having been disabled. I would recommend backing it up, though, on the off chance.

share|improve this answer
    
Unfortunatly my phone is not rooted :/ –  Martin Apr 16 '12 at 20:09
2  
This totally disables the voice input. OP only wants to disable launching of it by double pressing the home button. –  roxan Jun 13 '12 at 3:28
    
Excuse my ignorance, but how would one go about "removing" the apk? Does this also require root? –  Joe Dec 16 '12 at 13:47
add comment

http://kwatog.wordpress.com/2012/05/13/disabling-vlingo-voice-command-on-samsung-galaxy-s-ii/

  1. Install Go Launcher EX from Google Play. It’s free!
  2. Open the app drawer.
  3. Press and hold on the blue Voice Command icon until it starts shaking.
  4. Click on the X button and choose uninstall. Follow the instructions.
  5. Optionally, you can uninstall Go Launcher EX.

You are welcome.

share|improve this answer
1  
This totally disables the voice input. OP only wants to disable launching of it by double pressing the home button. –  roxan Jun 13 '12 at 3:28
add comment

I just upgraded my S2 to ICS and continued facing the same problem.. The solution for the problem is Settings -> Language and Input -> Keyboard and input methods. Make sure Google voice typing is unchecked... Problem solved...

share|improve this answer
1  
This totally disables the voice input. OP only wants to disable launching of it by double pressing the home button. –  roxan Jun 13 '12 at 3:28
    
Totally disabling the voice input would be okay. I can't remember I ever used it. –  Martin Jun 13 '12 at 5:24
2  
this doesnt work –  P-double Jul 5 '12 at 15:37
add comment
up vote 1 down vote accepted

Now I have installed Cyanogenmod 9 and this does not happen anymore. I don't think, this problem can be solved via settings of Samsungs Android version

share|improve this answer
add comment

for solving your problem

you must double press menu key when start s voice application press option key and go to setting . you must uncheck an option in 1 or 2 line .read text in under line .

you disable starting s voice via double pressing home button

sorry for bad english.. im from iran good luck dear

share|improve this answer
    
Thank you for your answer, but I can check this anymore, because I now have Cyanogenmod on my device. –  Martin Jul 8 '12 at 14:17
    
In the voice command settings there is no option to disable starting voice command via double pressing home button. –  Joe Dec 16 '12 at 11:10
add comment

I don't know about the S2, but I've just discovered that for the Galaxy Note, there's a setting "Launch voice talk" (launch by double-tapping home) that only appears when Vlingo is set as the voice recognition engine. If you choose Google, the option goes away.

share|improve this answer
add comment

Inside the voice command:

  • open settings → voice talk settings → motion
  • then uncheck double tap option or
  • uncheck motion activation altogether.
share|improve this answer
    
This "double tap" option has nothing to do with double pressing the home button –  Joe Dec 16 '12 at 11:14
add comment

On Droid Razr, running ICS, it is under Accessibility, in the system settings menu:

Scroll to the bottom and you should see a double tap home launch field, click it and it will allow you to set it to "none".

share|improve this answer
    
On the Samsung SGS2 with the original OS there was no setting like this. –  Martin Jul 12 '12 at 5:04
add comment

You can follow the following steps to disable Voice Command on ICS:

  1. From the home screen go to Settings then Applications.
  2. Find and select Voice Command in the Downloaded or All tabs
  3. If the Disable option appears - select and then ok. It will not prompt again.
  4. If not, select Clear data and then ok. The next time you mistakenly double click do not confirm the Samsung Disclaimer but select the back button instead.
share|improve this answer
add comment

protected by Community Dec 14 '12 at 11:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.