Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Stock Droid X, running 2.1. I have the USB Connection mode set to "Charge Only".

Whenever I connect the phone to my computer to charge, the SD card mounts as a drive in the computer. In the phone's USB Connection settings, it is still listed as "Charge Only", but the SD card is not available to the phone.

They only way to get it back is to:

  1. Change the connection mode to "USB Mass Storage" on the phone
  2. Unmount the SD card within Windows.
  3. Change the connection mode back to "Charge Only"

This works, but it is a pain to do this every time, when I should be able to just set the connection I want and plug it in. Is there anything I'm missing?

Edit: This happens with more than one computer - one running Windows XP, one running Windows 7. Neither have the Android SDK installed.

Update - The upgrade to Froyo seems to have fixed this issue.

share|improve this question
    
Have you tried to unset the USB Debugging? –  abhi Sep 14 '10 at 1:32
    
USB Debugging is not enabled. –  81bronco Sep 14 '10 at 1:56
2  
Do you have DoubleTwist installed? It helpfully mounts the SD card whenever you connect the phone. –  Al E. Sep 21 '10 at 2:02
    
I do have DoubleTwist. I just checked that setting and it is disabled. Good catch though. I might try and uninstall it just to see if that makes a difference. –  81bronco Sep 21 '10 at 19:37
1  
If the Froyo upgrade fixed this for you, could you add that as an answer and accept it (or accept one of the other answers) to get this off the unanswered list? Thanks –  GAThrawn Nov 30 '10 at 1:39

2 Answers 2

Motorola Mytouch 2.1

Settings -> connnect to PC -> Default connection type Choices are charge only / Sync / disk drive

I leave it at charge, unless I want to get to the SD card. It gives a alert that it's charge only, pull up that alert and it lets you change it.

share|improve this answer

Try this (not sure if it's the same for all phones):

  1. Go to Settings -> About phone -> USB Settings
  2. Select 'Ask on connection' (if it's there).

When you connect your phone via usb, it should ask you what to do. There was the option to 'do nothing' for me.

share|improve this answer
    
I don't see that option on mine. What version of Android are you using? Maybe that is something I'll get whenever the 2.2 update comes out for the Droid X. –  81bronco Sep 14 '10 at 4:21
    
@81bronco 2.1update1 on Samsung Galaxy S Gt-I9000. –  cofiem Sep 14 '10 at 5:15
    
No, these kinds of things vary from phone to phone (unfortunately). So, it is not connected to the Android version. –  Dr.Dredel Sep 14 '10 at 6:16
    
@Dr.Dredel is there some way to add/remove these types of things (available apps/widgets, number of home screens)? –  cofiem Sep 14 '10 at 10:19
    
I don't think there's a way to overwrite the pre-set "settings" options. I'm pretty sure that each phone manufacturer works with the carrier to offer exactly the options they see fit to add. Though Android is inherently malleable so there is probably *some way... I don't know what it is though. –  Dr.Dredel Sep 15 '10 at 2:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.