Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a tablet running Android 4.0.3 that I'm trying to connect to my company's Wi-Fi that uses a security certificate. I've obtained the certificate and successfully installed it on my tablet but when I go to the Wi-Fi settings to connect to the cooresponding Wi-Fi network, there is no where for me to specify to use the certificate for authentication. Is this an issue w/ this version of Android, am I doing something wrong, or is there something wrong at the cert level. We use the same cert on iPhones/iPads (converted for ios use) and the cert specifies which Wi-Fi network to connect to so I assume that is what's supposed to happen on my tablet. Any help would be appreciated.

share|improve this question
    
I can't check on ICS right now but on 2.x the popup when you click to connect to a new network has dropdowns for both CA and user certificates. You should try adding the network rather than relying on the cert to specify it, at least. –  Matthew Read Apr 18 '12 at 16:31
    
unfortunately when I go to manually add the network there is still no option for choosing certificates but I think I see the problem. The network is showing as secured using WEP. Another nearby network shows as secured with 802.1x and when I attempt to connect to that one I get the dropdowns for adding a certificate. Sounds like it's the way our wifi network was set up and secured that's the issue. –  Dan Snyder Apr 18 '12 at 17:12
    
so further testing and info from the admin who configured our company's wifi is that I should manually set it up as an 802.1x PEAP type network using PAP as the phase 2 security. I can then add the cert but once I save the network it shows as out of range. –  Dan Snyder Apr 18 '12 at 17:31
add comment

2 Answers 2

The option to choose a certificate is available with enterprise encryption (802.1x).

Judging by your comment, your android thinks it is using a different encryption method than it should, so have you attempted manually adding the network, and specifying the encryption type?

Please bear in mind that not all wifi cards and devices support that encryption method.

share|improve this answer
add comment

Try ProxyDroid from the Play Store. It might solve your problem.

share|improve this answer
    
Could you please give some more details on how the mentioned app is supposed to solve the issue? Thanks! –  Izzy Mar 29 '13 at 16:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.