Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

In an earlier question, I asked how to handle international phone book entries while traveling internationally. The simple answer was simply to store phone numbers in their international form, which works like a charm, except for one thing.

Incoming text messages don't always get assigned to the proper contact.

I may send a text to contact Bob, who's phone number is +52 333 555 12 12 (a Mexican number). He gets the text just fine, but when he replies, the message appears to come from simply 333 555 12 12. As a result, I end up with two conversations, one to 'Bob', and one to 333 555 12 12, which isn't associated with any of my contacts.

Is there a way to make my phone recognize these numbers as the same (without creating duplicate entries for all of my contacts--one with the +52 and one without)?

share|improve this question
    
Is the issue same as this but in reverse? –  onik Apr 20 '12 at 5:40
    
Yes, it seems to be. I'll try the solution there, though, and see if it helps. –  Flimzy Apr 20 '12 at 13:12
    
Did you ever solved this issue? –  Zuul Sep 8 '12 at 20:08
    
Nope... haven't found a solution yet. :( –  Flimzy Sep 8 '12 at 20:31
1  
@Power-Inside: Yeah, that would be the "without creating duplicate entries" part of my question. –  Flimzy Sep 15 '12 at 17:29

1 Answer 1

Propably not an easy and fast solution:

If MIUI supports your Phone, then install MIUI which is not like the many roms (unstable, cluttered, for "freaks"). If it doesn't support your phone, you could still search for an unofficial version here or on XDA-Developers.

You have the possibility to go into the Dialer-Settings and set a default country-prefix. If you stay in Mexico you just set the default prefix to +52 and the incoming SMS should have the +52 assigned. If your next stay is in Krungthep Mahanakhon (=Bangkok) then you just set it to +66. This works for me.

share|improve this answer
1  
Where do I find the default country prefix setting? –  Flimzy Oct 16 '12 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.