Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm having HTC Sensation and I use wi-fi on a regular basis instead of mobile network (bad data plan). For the old Android version there was no problem, I just switched of background syncing and set option "Sync only via wi-fi".

After the update mobile network turns on automatically...

I couldn't find exact duplicate of "Sync only via wi-fi" in the update.

I went to Settings->Wireless&Network->Usage->Menu->Usage Settings -> "Restrict background data", but two problems still arise:

  1. Can't get rid of Notification "Background data restricted"
  2. Mobile network turns on automatically when decides to sync.

Any advises?

share|improve this question
add comment

1 Answer

Maybe turning Data Enabled to off (Mobile network settings on CM9) might help. In that way, it'll sync only when WiFi is available.

share|improve this answer
    
At Mobile network settings I have: # Data roaming OFF # Data roaming sound OFF # Access Point Names # Network Mode # Network Operators # Enable always-on mobile data OFF CM9- what's that? –  Vairis Apr 26 '12 at 14:37
    
I think this might help. ICS introduced capping the Data Usage. There must be an option called as "Data Usage" which shows you a graph of your data usage. There's an option called as "Mobile Data". Switch that to off. Might be wrong. I'm on CM9. Worth a try anyhow. –  Abhishek Sha Apr 26 '12 at 14:39
    
CM9 - CyanogenMod 9. It's a custom Android ROM. –  Abhishek Sha Apr 26 '12 at 14:41
    
Can anyone please tell, why has someone, DOWNed my answer? You could suggest an edit ya know. –  Abhishek Sha Apr 26 '12 at 14:42
    
I don't know If we are talking about same "Data Usage": Settings->Wireless&Network->Usage->Mobile Network OFF This was the first thing that I did, nevertheless, this morning woke up with no credit and half updated Facebook statuses. –  Vairis Apr 26 '12 at 14:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.