Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Often when someone phones me, the phone just locks up. I can't slide the ring up to answer.

Sometimes the ring moves a little.. sometimes not at all. I just can't do anything until the caller stops ringing. The phone becomes responsive again and I have to call them back.

I have just upgraded to 4.0 from 2.3 and the problem is still there. I haven't rooted the phone or done anything special to it..

Apart from this the phone is always responsive and I don't really have any other problems.

How can I sort this out?

Phone: HTC Sensation-xe

share|improve this question
    
Sounds like they screwed up the threading. The phone process normally has high priority but it shouldn't be so high that it prevents you from interacting with the phone. –  Matthew Read Apr 26 '12 at 15:19
    
Try to install the rocked dial and in settings try to make it default app for receiving calls. Settings>caller ID –  avirk May 1 '12 at 15:28
    
Can you catch the error message using adb logcat when connected to the computer? –  NoBugs May 1 '12 at 22:22
    
HTC has inbuilt answering. By moving the phone into a vertical position it answers the call, if you face it towards the ground it rejects it. –  Deza May 4 '12 at 20:59
    
@avirk, installing rocket dial does seem to have done the trick, I've had no lock up for several days now. Please make your comment an answer so I can accept it! –  Mongus Pong May 6 '12 at 19:12
add comment

9 Answers

up vote 4 down vote accepted
+50

As user said my comment helped him and post it as answer.

Try to install the rocket dial and in settings try to make it default app for receiving calls.
Settings>caller ID

Also you can use free version of HD Caller ID which has option to overtake the default caller screen.

share|improve this answer
    
Thanks. although the rocket dial app does seem to be quite messy - the default dialer shows for a second before rocket dialer kicks in - it does seem to have fixed the problem. –  Mongus Pong May 7 '12 at 21:37
1  
In caller ID settings you will see an option Set the time delay for showing caller ID and set it to No delay by default it has set to one second. –  avirk May 8 '12 at 3:47
    
Outstanding! Thanks. –  Mongus Pong May 8 '12 at 8:44
    
Your welcome :) –  avirk May 9 '12 at 1:12
    
I updated my answer you can check it :) –  avirk Oct 9 '12 at 2:28
add comment

Is the phone connected to a PC/charger while you were trying the call? Try to have a good 'earth ground' at all times when handling a phone with capacitive screens. I had the same problem when my phone was connected to the PC/charger.

If that wasn't the problem, try using a different dialer app from the market and see if that brings up the problem.

share|improve this answer
    
No, its not connected. Doesn't a dialer app only affect outgoing calls? –  Mongus Pong May 1 '12 at 10:00
add comment

I've read the ICS ROMs on Sensation XE were buggy. Hence they delayed the ICS ROMs for (original) Sensation to fix the bugs. (Assuming you're using stock Dialer.) Update to the latest build of ICS that's been released for your device.

share|improve this answer
    
I just have.. No difference. –  Mongus Pong Apr 26 '12 at 19:13
add comment

Your best option will be to root and use a custom ROM and kernel... it's the touch screen drivers locking up

share|improve this answer
add comment

I had the same problem with my Droid 2. For me, it was a precursor to the hardware for touch interaction going haywire: it was registering other touches on the screen in a line on the right side. I was able to view them by opening a drawing program, or popping up the gesture screen in Dolphin HD. Random touches would appear up and down in a straight line.

This happened more frequently when I'd been outside working, or the phone got warm through other means.

share|improve this answer
add comment

It has happened to me on my Nexus S, running stock Gingerbread and now stock Ice Cream Sandwich, that occaisionally when I try to answer the phone the touch screen is unresponsive. I find that if I press the power button to turn off the screen (which silences the phone as well) and then turn it back on I can answer the phone.

share|improve this answer
add comment

Had the same problem with an htc legend, and in my case, I think the screen was screwed. Because I wa shaving problem when trying to write on the keyboard as well. At some point, whenever I was touching, it always acted as if I touched the top of the screen !!!

I bought a new phone

share|improve this answer
add comment

Its not Android problem its HTC Problem. I have experienced same problem few times. All you can hope is an upgrade of HTC Sense from HTC. Ring was introduced by HTC because there was problem with earlier approach of dragging up. Try to kill few unwanted process in your cellphone so that your becomes even more responsive.

share|improve this answer
add comment

It is an Android problem. I had the issue on a Samsung running Gingerbread. I still have the same issue iPhone.

Android is 98% there but when you can't answer a call then what the hell is the point of having a phone?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.