Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy Ace running Android 2.3.6. The problem is that when I'm in the middle of internet browsing, I completely lose my Wi-Fi signal. I've tried a factory reset which didn't help, I've tried different Wi-Fi hotspots, but that didn't help either. I know it's not the connection thats the problem, as the same Wi-Fi connections work perfectly on my laptop. Any help will be greatly appreciated.

share|improve this question

3 Answers 3

Here is the solution that worked perfectly with me: the problem lies in the DHCP settings of the ADSL router.

Follow these steps:

Login to your router and go to DHCP settings (for belkin its 192.168.2.1) and find the item called lease time. The default values of the lease time is usually Forever, which produces a bug in Android. All you have to do is to change the value of the Leasing time from forever to any other long value (depends on the routers options). Here I changed the value from forever to 2 weeks -- and since then I didn't have a single WIFI disconnect.

share|improve this answer
    
I recommend the default lease time to be something between 12 and 24 hours. –  Flow Sep 4 '12 at 9:34

Gingerbread has certain power saving options. Make sure that the Wi-Fi settings aren't set in such a way that make the Wi-Fi sleep if it's inactive. (The menu varies from phone to phone. So can't be specific)

share|improve this answer
1  
I've checked all that. I can't find anything like wi-fi sleep. –  DroidDev Apr 27 '12 at 17:04
    
Settings > Wireless and Networks > Wi-Fi Settings > [Menu Button] > Advanced > Wi-Fi Sleep Policy –  Mr. Buster Apr 27 '12 at 21:13
    
Wifi sleep policy has no effect on wifi during "in the middle of internet browsing". –  Mihic Sep 4 '12 at 10:00

worked for me as well. i have a tp-link rage extender TL-WA830RE, and had the same issue.. i increased the address lease time to 2800 minutes, and now wifi is working great, without any frustrating "ghost" disconnections .. thanks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.