Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I just rooted my phone and have been trying to create a task in Tasker with the Locale Execute Plugin to control the LED lights for different things.

Phone Type: HTC Evo 4G
Android Version: 2.3.5
ROM: AlterROM 0.0.4.1-RC1

I have followed instructions on every website I could think of except here so far and none of them work. Is there a bug in this version or something not allowing root commands from running?

Here's the command I'm trying to execute with Tasker & Locale Execute Plugin:

@! echo 1 > /sys/class/leds/wimax/brightness

(commands from here)

If I use a Terminal IDE to do the following:

$ su
# echo 1 > /sys/class/leds/wimax/brightness

It works, but no matter what I do in Tasker, it never asks me to grant it root access.

Any ideas?

share|improve this question
    
Which version of SuperUser do you have installed? –  TREE Apr 27 '12 at 20:02
    
@TREE It has SuperSU v0.87 - I managed to get the LED to turn on using Locale, but Tasker has so many more things that I would really like to get it working with that instead. –  Jared Apr 27 '12 at 20:12
    
The reason I ask is that it SuperSU may have remembered a "no" answer for Tasker at one point. You could try going into SuperSU and looking for Tasker or Locale Execute to make sure it's enabled. I notice that there is a 0.88 release of SuperSU available, too, that might help. I personally use Tasker with Locale Execute and Superuser 3.0.7 for root operations without problems. –  TREE Apr 30 '12 at 2:12
add comment

1 Answer

The plugin you're using is deprecated; Tasker now has built-in support for shell commands (under Misc->Run Shell). You can use root with this also.

EDIT: It's too bad that didn't work for you :( The last option I can think of is using Secure Settings Plugin. This can run shell commands too, and has the option of returning STDOUT and STDERR to Tasker as well. Good luck!

Also make sure that in your Superuser app you've set it to ask for permissions (or even automatically grant it - turn that on, run Tasker for it to get su permissions, then set it back to "ask").

share|improve this answer
    
I tried this out and it seems there might just be a problem with my Tasker app. It won't execute the command from there either. :( –  Jared Apr 27 '12 at 23:25
    
See updated comment. There's one more thing you can try to get root shell commands working. –  Dang Khoa Apr 28 '12 at 17:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.