Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Samsung Galaxy Ace (gt s5830), Android 2.3 OS, that I have rooted recently. The problem I'm having is that I am unable to run any Google apps on my phone. I have tried the Google Play app, and recently installed Google Earth, but when I start the app, it simply says, "force close" and gives the option to exit. I dont think that rooting it could be the cause, but the Google Play used to work before.

Can anyone tell me what the problem could be? What can I do so that I can run all Google products on my phone?

share|improve this question
    
How about a reset? –  roxan Apr 30 '12 at 5:59
    
you mean factory reset –  Abbas Apr 30 '12 at 6:10
    
Yes, a factory reset might help. –  SamSPICA Apr 30 '12 at 6:16
    
but that would revert all my settings and appliation, any other options. –  Abbas May 1 '12 at 12:14
    
So use e.g. Titanium Backup to backup all your stuff first. I experienced similar behaviour with several apps after rooting my Droid2 some time ago. A factory reset solved the issue for me. –  Izzy Aug 5 '12 at 9:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.