Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Does anyone know how to turn off the auto-complete feature when texting?

Sometimes I just want to text and not have my device try and tell me what I'm thinking. Other times this is OK, but I just want to turn off the autocomplete sometimes.

I looked in the phone settings (not very hard I guess...) and I didn't really see anything to allow this.

Anyone know how this is done?

EDIT:

I am using a Droid X.

share|improve this question
    
You're going to have to tell us what keyboard you're using, since I don't think stock does auto-complete. –  Arda Xi Oct 18 '10 at 18:44
    
I'm not sure what you mean... I just got my droid a few weeks ago, so I'm really new to this game... I'm using the standard textmessage layout that came with my DroidX –  EJC Oct 18 '10 at 18:48
    
Maybe it's not called auto-complete... I want to disable the bar that pops up above the keys when you are typing. It resembles auto-complete, but to actually complete the word you have to tap one of the suggestions... –  EJC Oct 18 '10 at 18:59
2  
I know you had your question answered, but I just wanted to bring up the fact that some phones have multiple keyboards available, i.e. my Samsung has the Samsung keyboard and the Android keyboard. I hated the Samsung auto-complete; however, when I switched to the Android one, it has auto-complete that is only activated when I hit the spacebar or use punctuation. Otherwise it uses the word I actually type. That's in 2.2 anyway. This is in Settings -> Locale and text -> Select input method. –  Chance Apr 11 '11 at 1:51

9 Answers 9

up vote 14 down vote accepted

The following works for me on an HTC Incredible. Hopefully your settings are similar.

Settings > Language & Keyboard > Touch Input > Text Input > Prediction. You should be able to un-check Prediction.

share|improve this answer
1  
Ah, thank you. The settings are similar, but a little different. The path is Settings > Language & Keyboard > Multi-Touch Keyboard > Show Suggestions. I should have seen that, but I kept overlooking it. :) thanks! –  EJC Oct 19 '10 at 13:14
1  
Yeah, I sometimes wish the settings were the same for all phones. Glad it helped! –  gary Oct 19 '10 at 13:53

I knew i had turned it on (autotype/autocorrect/wordpredict)since i first got my phone, but could not figure out how to turn it off, until now.

ON my Samsung Galaxy S I use an ANDROID keyboard. There are keyboard options and typing options for the phone under settings in the app area...but none of those will change the features of the Keyboard itself.

These features are accessed from the keyboard, on the bottom line (as it appears when you first start to type) ... there is a settings button (Looks like a cog or a sprocket) next to the GO button... YOU will find all the necessary settings you seek to turn on or off ALL OF THE Annoying features that your keyboard does automatically.

cgh

share|improve this answer

I have a Nexus S with 4.0.4 and i have turned off Settings/Language and Input/Spelling correction, but when writing SMSes it still corrects me. Then found another settings: Settings/Language and Input/ Android keyborad -> press settings button next to this, then down you have show correction suggestion (i'm turing it to always hide)

share|improve this answer
    
didn't help. Set auto-correction to Off: youtube.com/watch?v=3Up_p7vzdQs –  user14209 Apr 13 '12 at 12:05

For HTC One VX

Settings > Language & Keyboard > HTC Sence Input> Advance Settings > (turn off) Word Prediction.

share|improve this answer

on the galaxy s4 you can turn off the "predictive " text by going to settings in your apps. Settings...Language and keyboard. Hit settings (cog wheel) then turn off "predictive " text.

share|improve this answer
1  
Your answer does not help, where is this "predictive" text, I do not see it on JB...? –  t0mm13b Feb 21 at 0:20

Found it in Android, in Settings - Locale and Text - AutoComplete. You can still use the word suggestions bar since that is toggled separately.

share|improve this answer

As of 10/20/2014 for Android OS. Go to Settings / My Device / Language and input. Click the Settings icon for Samsung Keyboard. You will see Auto Replacement there with other items.

share|improve this answer
1  
Sure there's a SAMSUNG keyboard on a DROID X (a Motorola device)? –  Izzy Oct 23 at 13:48

Turn off tracing. This makes it impossible to disable the prediction part because they use same software bits. Then disable the prediction.

share|improve this answer

I have a Samsung Galaxy Glide. The predictive text feature can be shut of by doing the following:

  1. Open a text window like you normally would when you send a text using GO SMS Pro.
  2. On the bottom left hand corner you will see the settings icon which is the same as the icon for your phone settings.
  3. Hit this button and it will bring up a screen of settings that you can select.
  4. Uncheck the predictive text setting and voilà - no more annoying auto complete when you're trying to text!
share|improve this answer
    
oops. that should be left hand corner.... sorry! –  JANET Aug 7 '13 at 21:11
1  
You should find your Caps Lock key above the shift key on the left side of your keyboard. –  Al E. Aug 7 '13 at 21:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.